6

I'm using ArcMap (10.3.1) to connect to Postgres (9.4.5), which has Postgis version 2.2.0 installed. Create/Enable Enterprise Geodatabase wasn't used in this database. It's just a connection to the database. The connection itself works fine, but I get duplicate feature classes for each Postgres table. Only difference I've found is that first one has ability for address geocoding and second one looks quite normal. Also the first one has function Create Feature Class, and the second one Create Layer. The Postgres tables were created with FME 2015.1.

When dragging the feature class to ArcMap View, they both contain geometries and exact same attributes.

I checked that this shouldn't be related to Id, since I'm using objectid attribute, and ArcGIS recognizes it as Object ID data type.

View in the catalog:

Duplicate feature classes

Postgres tables:

enter image description here

  • 1
    PG 9.4 wasn't supported for geodatabase use by Esri until ArcGIS 10.4, and only with PostGIS 2.1. Please edit the question to clarify whether you have used Create/Enable Enterprise Geodatabase in this database. – Vince Mar 21 '16 at 11:19
  • Thanks! I edited the question. I didn't use Create/Enable Enterprise Geodatabase in this database. – Geolassi Mar 21 '16 at 12:18
3

Upgrading to ArcGIS 10.4 was the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.