4

QGIS 2.14 worked fine until a couple of days ago (ubuntu 15.10 wily), but now crashes at startup with only this error :

Segmentation fault (core dumped)

sudo qgis doesn't give any error but QGIS don't start.

qgis --noplugins doesn't help.

QGIS was installed from http://qgis.org/debian.

For development, I installed libqwt6. This might have been the source of the issue, but removal of all qwt packages and QGIS packages didn't help.

  • Did you compile QGIS yourself? Btw, sudo qgis should never be required. – Matthias Kuhn May 13 '16 at 14:49
2

Here's how I solved this issue:

  1. Uninstall QGIS and its libraries
  2. Install QGIS 2.8 from the Ubuntu repositories (I had to disable the qgis.org repo to accomplish this)
  3. Launch QGIS 2.8 and update all plugins. I was able to install an available update for qgis2web, even though that version of the plugin wasn't compatible with QGIS 2.8.
  4. Re-enable the qgis.org repo and update to 2.14

2.14 worked fine for me after this. I suspect something about the qgis2web plugin was causing problems, even when launching with --noplugins, but I can't be sure.

  • Thanks for sharing. I can't test your solution because I left Ubuntu for other reasons (I'm returned to Debian). – Pierma May 13 '16 at 4:23
  • "I had an available update for qgis2web, even though that plugin wasn't compatible with QGIS" - I don't understand. qgis2web is compatible. I don't know how to investigate further, but if anyone can help, I obviously want to know if it's causing crashes. I don't see how that can happen with --noplugins, though – Tom Chadwin May 13 '16 at 9:25
  • Sorry, @TomChadwin, I meant to specify the version number originally but left it off by accident. I included my speculation about qgis2web in the hopes that someone might be able to investigate further, but I'm by no means sure that your plugin was the cause. If you think such speculation is more harmful than helpful, I'll remove it from my answer. – dericke May 13 '16 at 15:56
  • @dericke No no, if that's your best guess at this stage, you might be right. I'm just saying that qgis2web is compatible with QGIS 2.8. – Tom Chadwin May 14 '16 at 6:53
  • Good to know. Not sure what the warning I was getting when I tried to update it in 2.8, then. If I find the time, I'll try to reproduce the bug in a VM. – dericke May 16 '16 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.