3

I have QGIS 2.14.0 installed on my machine (W7 x64, AMD FX-8150 3.6GHz, 8GB RAM, SSD) and I'm having issues with plugins not opening by default when I open QGIS. The message I get (for each plugin that is "broken") is:

Plugin MetaSearch: The plugin will be disabled because it crashed QGIS during last startup. Please report an issue and re-enable the plugin when the problem has been solved.

I also have QGIS 2.8.6 installed and do not get these issues when using this build.

Within QGIS 2.14.0, I am able to open the "Manage and Install Plugins" window and enable the disabled plugins once QGIS is open with no issues. They work as expected. This issue seemed to start around the same time as some Windows updates a couple of weeks ago, however other PCs on the network with QGIS 2.14.0 installed and the same plugins received the same updates and are working correctly. I have also disabled some of the Windows updates and re-installing QGIS 2.14.0 since then with no luck.

EDIT: I've noticed the problem doesn't occur on the same PC for different logged on users. I've tried temporarily renaming the folder "C:\Users\.qgis2\" but one of the plugins (MetaSearch) still complains. Tried reinstalling the plugin - still got the issue.

EDIT: Two weeks later and after installing a new update for the Contour plugin, I no longer receive the error for Contour or my own plugin (no update). I'm still getting the issue with "Metasearch".

EDIT: 26-04-2016 - The issue appears to have solved itself. I believe the IT team in our company have been installing various updates and changing various settings in our accounts. Not quite sure what's changed but it's no longer an issue. Will update with answer if I find out exactly what caused this.

  • Is it a particular group of plugins that this happens to or all of your installed plugins? – Kingfisher Mar 23 '16 at 12:02
  • I've noticed it complaining about "MetaSearch", "contour" and a plugin I've written myself called "DavesTools". All three plugins can be reactivated successfully manually in the plugins window. – davehughes87 Mar 23 '16 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.