2

I am trying to georeference a raster (jpg). I can easily create a geotiff, but when trying to use the QGIS georeferencer to create a wld file instead, something goes wrong. I have the target CRS set, and using liniar, the wld file is created. But when I load into QGIS an error pops up and says the wld file contains no CRS, and thus the raster loads into the standard CRS (which is not the CRS I had to georeference the raster to). Anybody knows which knob I need to switch on or off? I can find plenty of pages explaining how to georef to geotiff, but this one I cannot find.

EDIT: I was following the guide here: http://www.qgistutorials.com/en/docs/georeferencing_basics.html

first for the geotif, and then I tried to modify settings to save as a world file. I set to liniar, set target crs to 4044 as pr the instruction on the page. But as was said, this is not saved to worldfile. and then I checked create world file. all filenames for .wld, .point and .jpg are identical.

using QGIS 2.14

  • 1
    World files never contain any information about the projection. Sometimes projection is saved into a separate file (.prj or .xml, for example) but I do not how QGIS behaves. But if you add tiff+tfw into QGIS project the CRS selector window should open and you can give the correct CRS there. – user30184 Mar 23 '16 at 9:49
  • Please edit the question to contain an example of the exact file names you are populating for the image, the world file, and the coordinate reference information. – Vince Mar 23 '16 at 10:37
  • The conventional form for a world file of a .jpg is ".jpw" – Vince Mar 23 '16 at 14:10
1

In the menu, choose Settings -> Options -> CRS. Under CRS for new layers, you can select Prompt for CRS.

That way you always will be asked for the CRS, and not assigned a default.

If you have a shapefile in the same CRS, you can duplicate the .prj file to the name of the raster. Then QGIS can read that to load the raster without prompting.

  • I don't know if this really is the issue. but I ran through the process again, just this time I did what you suggested and got the prompt. The prompt also came when opening the raster in the georeference tool. this time the world file worked as expected. Thanks... – Michael Riis Trampedach Mar 23 '16 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.