1

I'm using the new what3words geocoding service for ArcGIS Desktop (10.0 SP 5) and keep getting the following error message: "there was an error trying to process this table"

Checked through the threads and nothing applies to my data thus far. it's sample data of a small size, less than 100. The data was provided by what3words, so i know it works! There are no special characters, null values, extra spaces or anything else that typically might cause an issue with geocoding. Tried processing as csv, xls, dbf. Still no luck.

So I know the data is good. I know what3words' geocoding service works (the other features work fine). I know the issue is ArcGIS Desktop reading the data!

A sample of the data (from csv) is provided below.

what3words Lat Long

zones.runs.newly 51.549307 -0.440708
voting.flames.hunter 32.687406 -117.191119
index.home.raft 51.521251 -0.203586
shoelaces.upholding.spike 51.054859 0.016843
loops.keener.cooks 50.866066 2.903226
spoken.rally.parent 32.622561 -117.070773
burn.fresh.atomic 32.721688 -116.993317
timeless.goal.only 51.050655 2.396777
parent.verge.pyramid 50.617925 3.050013
operated.comic.abruptly 50.952067 1.913351
guzzle.digit.switch 50.824668 2.929794
ducks.august.gymnasium 51.110729 1.259901
volcano.sorters.tribune 50.865904 2.903397
cards.punchy.orbit 50.980366 -1.395319

  • 3
    csv is an abbreviation for "comma separated values". I don't see any commas in your sample. en.wikipedia.org/wiki/Comma-separated_values – Kirk Kuykendall Mar 23 '16 at 16:13
  • @KirkKuykendall the data is directly from a csv file. just copied/pasted values using sublime text so people can see the data i'm working with. – barryjames Mar 23 '16 at 19:36
  • Assigning a csv extension to a text file will not automatically introduce commas. I suggest putting commas between, each, value. – Kirk Kuykendall Mar 23 '16 at 19:42
  • Hi @KirkKuykendall Really appreciate your feedback. In the interest of finding a solution, please see the sample data below, which contains commas. The problem still exists with ArcGIS Desktop not being able to process the file. I welcome your suggestion. Thanks Barry w3wgiven,Lat,Long zones.runs.newly,51.549307,-0.440708 voting.flames.hunter,32.687406,-117.191119 index.home.raft,51.521251,-0.203586 shoelaces.upholding.spike,51.054859,0.016843 – barryjames Mar 23 '16 at 21:07
1

I am having the same issue and have reached out to what3words for some help. I have an even smaller dataset (4 addresses) that works perfectly fine in batch geocoding on ArcGIS Online. When brought into Desktop, I get the same error you do.

I also tried converting a file geodatabase table with just the address, same result, so it's not a .csv issue.

As you indicated as well, the other functions, like singular search of a w3w address, works perfectly fine.

If/when I hear a response, I'll post here.

  • Zac - the data above is a file sent to me by the guys at what3words. so it works. you can search the 3 words and get back the lat-long on the geocoder. so the problem is arcgis desktop itself, not what3words. not sure if it has something to do with python or some other setting. i've used the arcgisonline geocoding since 10, so i'm not even sure where to begin with this desktop geocoding issue. hope someone can shed some light on this! Barry – barryjames Mar 24 '16 at 12:44
  • Thanks! I have a call with them next week. I want the ability in desktop to only have what3word and geocode those. Works in AGOL, but not in desktop. Will post back when/if I get it resolved. – zachawii Mar 29 '16 at 19:20
  • did you ever get any response on this? qgis works perfectly – barryjames Jul 6 '16 at 23:37
-2

There doesn't seem to be a solution for this as yet. As a workaround, QGIS will do the geocoding perfectly fine.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.