6

I have some configuration or something like that where i can do to limit the size of log geoserver (like 1 Gb), or maybe delete entire log like 1 time of week?

Because my logs never stop to increase, like 5 GB, 7GB etc

7

The size of the geoserver.log file is already limited to 10MB, it's then going to roll it and keep a few copies (3 or 4).

If you are deploying on Tomcat, the size of catalina.out is out of GeoServer control, and the file is not rolled. Your best option is to disable "logging to stdout" in the GeoServer log configuration: http://docs.geoserver.org/stable/en/user/webadmin/server/globalsettings.html

2

I just solved this by adding this line:

log4j.appender.geoserverlogfile.MaxFileSize=10000KB

to a file

[GeoServer data dir]\logs\[Your logging profile].properties

Setting value to "10MB" didn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.