1

I've been using dissolve to successfully merge polygons (which may or may not overlap) representing mining tenements so that I can calculate their total coverage area (using the geodesic area calculator). However, in one case the output of the dissolve has an 11% greater area than the total area of the input polygons.Have attached a picture of the output.

The input data is from multiple shapefiles. I've selected and merged these into one feature class. I've repaired the geometry of the feature class before running the dissolve.

The dissolve output feature is complex with multiple slivers. I thought that these slivers may be the problem. But eliminating some of them made very little difference to the geodesic area calculation. I'm baffled!

Does anyone gave any suggestions?

dissolved feature

  • Please edit the question to specify the source of your data (e.g., shapefile, fileGDB, enterprise GDB). – Vince Mar 24 '16 at 2:53
  • 1
    I'd say repair geometry and try again – FelixIP Mar 24 '16 at 2:57
  • This looks a lot like Northern Territory, Australia. If so, I suggest using GDA_1994_Australia_Albers projection (EPSG: 3577). You can set your data frame to that projection, and calculate geometry on your area field. – Fezter Mar 24 '16 at 3:00
  • Many thanks @FelixIP I've done that and it made no difference - have clarified in the question. – dartmoor Mar 24 '16 at 3:10
  • 2
    Database settings on DD sets, e.g. precision could cause it – FelixIP Mar 24 '16 at 3:35
1

Try starting an editing session with your original feature class. Use the Merge tool in the Editor dropdown and combine your features. The area may not update without calculating. I find the best way is to open your attribute table and go to your area field. Do calculate geometry. The calculation should reflect the new amount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.