0

When I use the tool "Sort" within modelbuilder I can not access the resulting file from other tools within modelbuilder in order to continue with the model. If I, for example, sort the file PR into PR_sort and then try to add a field I get this message: "ERROR 000229: Cannot open C:\LN_Slump\PR_sort. Failed to execute (Add Field)."

Or if I try to rerun the sorting I get "ERROR 000210: Cannot create output C:\LN_Slump\P_sort. Failed to execute (Sort)."

Doing the same things outside modelbuilder by using one tool at time is absolutely no problem (but very unpractical).

Does anyone have a suggestion to what might be wrong and how to solve the problem?

I am using ArcGIS 10.2.2

0

you need to add .shp to the end of your Sort function Output Dataset. I'm not 100% Sure why that is, it could be because the Add Field function brings in a %%%%.shp variable and is specific to that. Either way it ran fine for me once I added the .shp to the output. Also the second error is because you are trying to create something that already exists. Eventhough you were running into the issue with the add field portion, the Sort portion was working fine and so you would create your shapefile. Hope this helps.

enter image description here

  • Fantastic! Solves everything! How could you figure out that? Thanks a lot! /Sofie – Sofie W Mar 28 '16 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.