I have an A0 map. I want to put a table underneath it. I want to insert an Excel object as the table. When I do this, the size of the table is 19 fields/columns. I cannot increase this number of columns, even though this is only half the width of an A0 portrait page. The table is only 32.1cm wide when the page is 84.1cm wide. I want it to, effectively, display 84.1cm's worth of cells, not just stretch 19 columns 84.1cm wide.

I have set the printer as the A0 plotter (HP designjet HPGL/2). I selected A0 page size in the Excel object. In fact I set this as the default setting in case a non A0 default setting was causing the problem.

I know that Word cannot print anything bigger than 55.7cm, but Excel is supposed to be able to print more (presently the object isn't even 55.7cm wide...). Is it correctc excel can print A0 if an A0 printer's installed? I can edit the size of the Excel Object in Arcmap, but this only makes the table bigger, not display more fields. I have also tried opening the excel object from a file rather than typing data straight in. This file contained far in excess of 19 fields, but the object only displays 19.

  • I find copying and pasting the excel sheet works best but it only leaves you with a static image. I too have tried to insert an excel sheet as an object in the layout to keep it linked but lose data because I only get the 19 columns - ridiculous!
    – Paul
    Commented Dec 31, 2014 at 18:55

1 Answer 1


did you try stretching?
I know I have had this issue with the number of rows; and stretching allowed me to see them all.
I had more rows than would fit on my page.
So I had to copy the object several times and stretch to different sections of my data.
Then place them so they read like columns (or sub-tables).

In fact I just tested it with an sde table and I see 32 columns by stretching the object box. pic

I see what you are talking about. It does it with *.xls files.
I am not sure which method you are using to do this.
1. use the add data tool and the open the attribute table, and use the add to layout tool?
2. use the insert pulldown menu> object> from file> and select your xls file? 3. Also not sure what version of excel you are using? 2003, 2007, 2010?
4. Also is your file *.xls, or xlsx?

I see inconsistent results.
I am able to see all the fields of my 2003 xls file (my excel version is 2007), but don't see any data.
However the next time I tried I could not see all the fields but could see the data.

I am testing also with setting the default printer to my plotter and setting up the print area to match a large paper size so that the print area will cover all of the fields.
Then adding it to the layout.
I do think it is somehow related to the page setup but can't confirm.
I am able to see all fields but no data for *.xls, and *.xlsx files.
The object insert always only gives a page size view of the data no matter what.
My suggestion for a workaround would be to insert the xls into arcmap, and export to dbf.
This will lose any sheets that are in the xls (you would need to export a seperate dbf for each sheet).
But will add an oid to each table.
This is most likely one of the main causes of the problem you see.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.