0

I am joining a large excel spreadsheet to a feature class. Both have a little over 8,000 records. I have gotten this particular join to work before, unfortunately, I had to redo it. This time I cannot get it to join at all. Both of the data types for the table and the attribute table for the particular field the join is based on are the same type. I have tried remaking the spreadsheet. I have used a different mxds with copies of the feature class uncorrupted from this prior to the join not working. I have tried everything I can think of, checking for any reason it may not be working. I have now tried it multiple times and it simply won't do what it has already done before. Usually, I have no trouble at all with joins.

Does anyone have any insight why I am having this trouble?

3
  • 4
    -1 not enough information or detail on the described problem or attempts to resolve it.
    – Stella
    Commented Mar 28, 2016 at 20:50
  • What are the symptoms of "not working"?
    – PolyGeo
    Commented Mar 28, 2016 at 21:04
  • The result is null values for all rows in the fields of the table, not the fields of the feature class though. Even though their are roughly 8000 records that would match and appear as a result of the field the join is based on.
    – Colin
    Commented Mar 28, 2016 at 21:09

9 Answers 9

5

Four things need to be in place for a join to be successful.

  1. The fields your using to join, both have to be the same format, i.e. string or number. The field names don't matter but the format does.
  2. The data should be in the same case if string, i.e. Upper, Lower, or Proper. Because Name, NAME, and name are not the same in a join.
  3. Leading and trailing spaces, very easy to add by mistake, use trim to remove them.
  4. Make sure the join field is not populated by a excel formula, it needs real vlaues.

Most of the time that works, if all else fails try the CSV route and this will rule out any XLS, XLSX issues.

5

In case anyone stumbles on this, here's my experience with a similar problem. Short answer: the problem was with my shapefile and not my table. Using an earlier version of the shapefile cleared up the problem.

I was doing everything right and getting no matches in a table join. I reformatted my table 10 different ways and nothing worked. Then I tried to join a dummy table - 10 rows and 2 fields that I knew should match. I still got not matches. This made me think that the problem was with my shapefile and not the table. I tried an earlier version of the shapefile with the same table and it worked as expected. Somehow I corrupted the shapefile. I have no idea how, but using an earlier version fixed it.

1
  • I had this issue. Simply exporting the shapefile and joining on the new shapefile worked for me. Commented Aug 16, 2023 at 4:25
2

Try saving the excel spreadsheet as a CSV, then opening it in ArcMap and exporting it to a DBF. Then you should be able to perform joins and field calculations. Also, check the length of your fields in the spreadsheet- they cannot be too long.

4
  • I have now tried this too. Giving me null values for every row in the dbf table part of the join.
    – Colin
    Commented Mar 28, 2016 at 21:11
  • 1
    Do your field names include spaces or special characters, or are they longer than 10 characters? This is usually the solution that I find when running into this problem. If this is not the case, then consider editing your question to provide more detail about the spreadsheet and fields (field name length, type, etc). Commented Mar 28, 2016 at 21:31
  • Use 8 characters long name for your dbf table. If common field is string trim it in both feature class and table
    – FelixIP
    Commented Mar 28, 2016 at 21:36
0

If on the Join Data window (after right-clicking feature > selecting Join) the drop down box for "2. Choose the table to join..." does not show the spreadsheet you have added then my guess is you have more than one dataframe and you have added the spreadsheet to the wrong frame. Therefore, you are not seeing the spreadsheet show up in the Join Data drop down.

0

I had the same issue, the formatting fixed my issue like a charm! Although ArcMap layer has a column with all numbers it was defined as a 'String' so I had to change my Excel file columns from the 'number' format to 'text' and the join worked. Many thanks Bill Chappel, above.

0

I was able to solve this issue by removing the CSV file and uploading an XLSX file.

0

I just had this problem with a simple Table Join and thought it was an issue with the table creation. It turned out to be the Shapefile side of the Join causing the issue as explained by some above and the original poster. In my case I have a California County Parcel Shapefile with many records where in I created query and the selected record set was used to create a new layer with "Create layer package". I then used that new layer but this was causing the issue with the Join.

0

I fixed the problem by removing a definition query on the feature class I am joining to.

-1

This happened to me when I changed the name of the shapefile in the Table of Contents. Removing the file and then adding back with the original name fixed the problem.

1
  • The question doesn't mention shapefile at all, so I'm not sure if this is an answer to the question
    – nmtoken
    Commented Feb 27, 2020 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.