0

This question already has an answer here:

I have been trying to style some OSMM data using their supplied QML files which include a font with some of their symbology in. I've added the font to my system (ubuntu 14.04 LTS) and when viewed in FontMatrix and other system font tools it looks fine:

enter image description here

But when I come to use it in QGIS the font has no glyphs visible and I end up with ugly rectangles instead of my symbols.

enter image description here

Is there some trick to get QGIS to recognise this font?

marked as duplicate by Ian Turton Apr 3 '17 at 7:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The qml/sld - files from github are somehow not right. Qgis tells me some lines/positions that are incorrect. For example there is data-pjax-transient in tags without a value. I think there the ="true" was forgotten several times. As well as other tag-mismatches. The ones directly from OSMM are working. But to your question :) Are the truetype fonts that were delivered in the system folder? (/usr/share/fonts/truetype) – Matte Mar 29 '16 at 15:05
  • Yes, i've tried it in both ~/.local/share/fonts/OSMasterMap.ttf /usr/share/fonts/truetype/maps/OSMasterMap.ttf (and done fc-cache -fv) – Ian Turton Mar 29 '16 at 15:13
  • Just trying again, and i realized that the .ttf is wrong as well. I got the one from ordnancesurvey.co.uk/resources/carto-design/… directly, not via github, and they are working. – Matte Mar 29 '16 at 15:15
  • cmp (and diff) think they are identical – Ian Turton Mar 29 '16 at 15:23
  • Just tried again on a debian sytem, and it got the same problems there. Maybe because of the freetype renderer that debian/ubuntu is using instead of truetype. Sry for your time – Matte Mar 29 '16 at 15:59