4

Unexpectedly Qgis won't open today. Error code is:

Couldn't load QGIS utils.
Python support will be disabled.

Traceback (most recent call last):
  File "", line 1, in 
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 20, in 
    from future import standard_library
ImportError: No module named future

Python version:
2.7.10 (default, Oct 14 2015, 16:09:02) 
[GCC 5.2.1 20151010]

QGIS version: 2.15.0-Master 'Master', exported

Python path:
['/usr/share/qgis/python', u'/home/simon/.qgis2/python', u'/home/simon/.qgis2/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client']

I've done some digging around similar errors to no avail. utils.py imports a module from __future__ successfully then standard_library from future unsuccessfully. This suggests that future/standard_library should work though. I've just reinstalled (xubuntu, debian nightly ppa) and still no joy. Qgis has been working fine until now, although I've not opened it for about a month or so. Searching for future in /usr/lib doesn't give any other exact matches: futures.py in /python3.4/asyncio, fix.future.py in python3.4/lib2to3/fixes, the same file in python2.7 folder...

2.7 isn't new, so 2.7's future has assumedly never had standard_library in it, right? What am I missing here? Could an independent package have decided I no longer need a more recent version of python, I okayed it for autoremove, and it turns out Qgis needs that version of python's future?

OS is xubuntu 15.10

  • is there now some code on stackexchange which autodeletes "Hi all" if I put it at the start? Feels nice to open with something friendly rather than dive right into "help me"... – dez93_2000 Mar 29 '16 at 14:23
  • 1
    I believe so as this was discussed here: Should 'Hi', 'thanks', taglines, and salutations be removed from posts?. – Joseph Mar 29 '16 at 14:32
  • 1
    I had the same problem yesterday after upgrade to Qgis 2.15. I tried many things,but the only solution was to downgrade to the longterm release (LTR) version 2.8.8. It' working fine now I hope there is another solution, but this was the emergencial one for me now – user70252 Mar 30 '16 at 13:42
  • 1
    2.14 is much closer to 2.15 and given that 2.15 (nightly) is an option, the reliability of an LTR should not be a requirement. – Matthias Kuhn Mar 30 '16 at 14:08
  • 1
    Which operating system/distribution are you using? – Matthias Kuhn Mar 30 '16 at 14:09
5

On a recent ubuntu system like yours, the following command should work (I don't have ubuntu, so I cannot test)

sudo apt-get install python-future

on Fedora it's

sudo dnf install python-future

If this does not work you can also try

pip install future
2

This is a know issue, reported at https://hub.qgis.org/issues/14577

It's also discussed in http://osgeo-org.1560.x6.nabble.com/QGIS-has-no-future-tc5258029.html where Jürgen suggests:

The packages are thin wrappers around pip, that actually installs or uninstalls the package. So they involve downloads from pypi - I guess it's a proxy issue that blocks that for you (%OSGEO4W_ROOT%/var/log/setup.log(.full) should have more details).

  • Thanks Anita. Looks like this is a live discussion so fingers crossed someone sorts it out at some point down the road - looks like Jurgen's going to. Cheers! – dez93_2000 Mar 30 '16 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.