5

I am trying to use ArcGIS Pro to create a 3D scene using an elevation surface (.tif) generated from drone imagery. The tif is projected and contains the elevation information, but I cannot get ArcGIS pro to accept the layer in 3D - only in 2D.

I can use the raster as an elevation surface in the scene: Right-click Scene in Contents Pane > Properties > Elevation Surface > ground > navigate to raster layer

But, the layer doesn't remain 3D when I publish the Web Scene to ArcGIS Online.

How do I use the raster as the actual 3D layer?

enter image description here

7

It sounds like you want to set the raster as its own elevation source.

To do this, go to map properties, Elevation Surfaces, and hit Add Surface. Then hit Add Source on the ensuing dialog and add the raster again.

THEN, in the raster layer, open its properties, go to Elevation tab and set it to be on Surface 1.

| improve this answer | |
  • I did this but it still does not let me drag the layer into 3D – NULL.Dude Jun 22 '18 at 13:04
1

When you have a scene layer up in ArcGIS Pro, you'll see at the bottom of your Contents window a group called Elevation Surfaces. When you right click Ground you'll see the option to "Add Elevation Source". Select your desired raster and add it as your new elevation surface. This won't display anything in itself but will serve as the new elevation for layers to be draped on in Scene.

enter image description here

| improve this answer | |
1

I was having a similar issue, and I think that I may have found a solution. It seems that .lasd (LiDAR las dataset) files show up as 3D Layers when I convert my map into a scene.enter image description here

Once I had the .lasd file as a layer within my scene, I was able to add in other georeferenced .tiff files that were associated with that .lasd. Note: Those .tiff files are still showing in the 2D layers part of the table of contents, but they display in 3D dimensions.

Also note that I did not have to set the elevations of those .tiff files to the .lasd or an elevation raster based on that .lasd. My recommendation is to create a map with all of the associated data that you would like to have in a scene, and then, within the catalog pane, convert your map to a scene. The data seems to come in more seamlessly by taking that route.

Note: lasd is not turned on in the photo below but hillshade (.tiff) displays in 3D.

enter image description here

| improve this answer | |
  • I have not attempted it myself, but it is possible that a TIN might also show up under 3D layers. TIN can be created for any raster with a Z value. – JamesS Dec 18 '19 at 21:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.