2

Here in South Africa, at our very small company, we often make use of this simple xml file (downloadable from http://aerial.openstreetmap.org.za/aerial-osm-org-za-tiles.xml) to link to this imagery: aerial.openstreetmap.org.za since any other OSM imagery simply doesn't enjoy our archaic internet speeds.

Problem is in January this year suddenly my QGIS (back then version 2.12 i think) started to refuse to load the xml file (I used to find the xml file via the load raster button and wham it would load imagery for a polygon which was already loaded, I never changed the process of loading the imagery). Now I get this error and then it refuses to load the imagery:

Unsupported Data Source: C:\Users\ColinF\Downloads\aerial-osm-org-za-tiles.xml is not a supported raster data source.

The interesting thing is that my colleagues are also using the same xml file (just copied onto their PCs) and their QGIS is linking just fine to get the imagery (via the same process). I downloaded a new xml file and still get the same error.

So what am I doing wrong? Or is there a small setting somewhere I have changed on my QGIS?

We use very similar PSs spec wise and highly similar operating systems, one thing is they are using a QGIS 2.8.1 version and I am using 2.14.0 (however recently colleagues have used 2.14.0 with the imagery so I'm baffled). I have also tried reinstalling it back to 2.8.1 without any success.

0

I can not reproduce your error. I can load the file on QGIS 2.8.3 as well as 2.14.1 on the same computer running on Windows 7 and Linux Mint.

As a workaround, you could try the TileLayer plugin. From

https://gist.github.com/Firefishy/382a575dc40f554192d7

you can download a tile server definition file for several tile services from za-ngi hosted by openstreetmap.org. Put the file into a separate folder anpd point to it in the plugins settings dialogue.

  • Thank you AndreJ, this does work as a workable workaround for me. Really appreciate the help! – Colin Fordham Apr 5 '16 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.