1

I try to seed a wms service that is very very slow. Therefore the seeding fails with the message "Operation timed out after 600000 milliseconds with 0 bytes received".

It seems not to be possible to set the time out time. I found the connection_timeout option in the wms-source of the mapcache.xml-file but it not work and changed the value from 600 to 1800:

<connection_timeout>600</connection_timeout>

to

<connection_timeout>1800</connection_timeout>

but the error message remains the same "... 600000 milliseconds ...". The change seems not to be adopted. Even after a restart of the apache webserver.

The command for the seeding

mapcache_seed  -c mapcache.xml -t osm_eu_3035 -e 542100,-369400,7530900,6619400 -z 0,10

The osm_eu_3035 service uses the local very slow wms service.

What did I wrong? Is there any other possibility to increase the time out time?

1

It could also be an apache setting. eg: https://httpd.apache.org/docs/2.4/mod/core.html#timeout

Reducing the size and metatiling can also help

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.