2

I am using QGIS version 2.14.0 (Essen) and have downloaded the latest version of the Time Manager plugin in order to do some spatial-temporal analysis.

I have imported a csv file into QGIS and made a join wih a shapefile in order to import all the time data on the shapefile. However, when I use this shapefile in Time Manager, it recognises the data as the start date appears in the player time frame, but the video and animation do not load. In the logs I see the folowing error message:

Exception in function <function refreshTimeRestrictions at 0x0ECA18F0>:'ascii' codec can't encode character u'\xe9' in position 27: ordinal not in range(128)

I am using time data in the followng format, which should be compatible with Time Manager:

YYYY-MM-DD

Sample data:

start_date          end_date            start_date_auto     end_date_auto 
2016-04-01 00:00    2017-11-01 00:00    2016-04-01 00:00    2017-11-01 00:00 
2016-01-01 00:00    2018-01-01 00:00    2016-01-01 00:00    2018-01-01 00:00 
2015-03-09 00:00    2016-12-31 00:00    2015-03-09 00:00    2016-12-31 00:00

Anyone know where I am going wrong?

closed as off-topic by underdark Jan 13 '17 at 18:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    you might want to post some of the data from the csv. – jbchurchill Apr 1 '16 at 12:39
  • charbase.com/00e9-unicode-latin-small-letter-e-with-acute This is the character that is causing you problems. You shouldn't have this in the date field – Albert Apr 1 '16 at 12:44
  • I tried but it still doesnt work. now the error message is as follows (i truncated it as it is toolong): Exception: Could not match value 03-02-16 00:00 with any of the supported formats. Tried ['%Y-%m-%d %H:%M:%S.%f', '%Y-%m-%d %H:%M:%S', '%Y-%m-%d %H:%M', '%Y-%m-%dT%H:%M:%S', '%Y-%m-%dT%H:%M:%SZ', '%Y-%m-%dT%HZ', '%Y-%m-%d', – philippe Apr 1 '16 at 13:09
  • 1
    To be in the safe side, I would avoid using any type of symbols in the entire file (including file name, columns, data etc). – Joseph Apr 1 '16 at 14:02
  • 1
    Please share test data otherwise we are limited to guessing ... – underdark Apr 2 '16 at 12:01

Browse other questions tagged or ask your own question.