3

Possible Duplicate:
Re-projection in Geoserver

I've got a WMS service that publishes layers in WGS84 (EPSG:4326). I have several AutoDesk users that need to use the imagery in NAD83 (EPSG:2227). I have GeoServer 2.1 set up to cascade the WMS and reproject it.

Problem is that as soon as I turn on SRS handling to reproject to declared SRS the reprojected WMS layer fails. What am I doing wrong? Is GeoServer capable of doing the reprojection?

marked as duplicate by underdark Sep 21 '12 at 7:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Could you elaborate on what you mean by the reprojected wms failing? What's the projection of the original data? – R.K. Jan 13 '12 at 0:33
  • 3
    also can you clarify what you mean by "turn on SRS handling to reproject to declared SRS"? reprojection is on by default you should not be setting the declared SRS of the cascading layer unless the native SRS is not being found. – Ian Turton Jan 13 '12 at 8:14
  • @RK If I reproject the wms from WGS84 to NAD83 I get a 404 error. When I don't reproject the WMS it works just fine with lat/long coordinates. The original data is in WGS84. – calmapnerd Jan 13 '12 at 17:59
  • @iant I've tried leaving the SRS in native SRS and adjusting the wms request to include the new projection. When previewed in openlayers it centers on 0,0 and just shows black with a max scale of 1:5000 – calmapnerd Jan 13 '12 at 18:31