1

I am struggling to get Google Earth working properly in Ubuntu 14.04 64bit. The program opens correctly and does not crash, as many report over the web. But it has trouble working with the graphics card, returning a "clamped polygons not supported" message.

(The map in question was rendered properly in Windows in a dual-boot machine, so the card itself is not the problem, it would seem.)

I downloaded/installed the 64bit .deb and also the 32-bit libraries that are required, as instructed here and also here. I also tried installing the 32-bit GE with even less success.

Has anyone solved this issue? I am now inclined to install the win version of GE over wine, but wish to ask for advise first.

Or might installing an earlier GE version do the trick, as suggested here?

Some possibly relevant info about my graphics card follows

$ lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
Subsystem: Dell Device [1028:052e]
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 2000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
Subsystem: Dell Device [1028:052e]
Flags: bus master, fast devsel, latency 0, IRQ 47
  • You should try asking this on AskUbuntu – DPSSpatial Apr 4 '16 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.