1

I am having an issue with running the gdalwarp command from command prompt. Basically I have a raster WGS84 file, which I would like to reproject to spatial reference which is using the Azimuthal Equidistant projection, but with "cubic" resampling method. This is the syntax that I am using:

"C:/gdalwin32-1.4.1/bin/gdalwarp.exe" -s_srs EPSG:4326 -t_srs "+proj=aeqd +datum=WGS84 +lat_0=40.81266 +lon_0=14.414252" -r cubic -of GTiff "C:/vesuvius_wgs84.tif" "C:/vesuvius_cubic_aeqd.tif"

(40.81266, 14.414252 is the center of the raster)

For some reason when I press "Enter", the vesuvius_cubic_aeqd.tif file is not created, but instead I get the following text printed on my command prompt:

gdalwarp [--help-general] [--formats]
    [-s_srs srs_def] [-t_srs srs_def] [-to "NAME=VALUE"]
    [-order n | -tps | -rpc | -geoloc] [-et err_threshold]
    [-refine_gcps tolerance [minimum_gcps]]
    [-te xmin ymin xmax ymax] [-te_srs srs_def]
    [-tr xres yres] [-tap] [-ts width height]
    [-ovr level|AUTO|AUTO-n|NONE] [-wo "NAME=VALUE"] [-ot Byte/Int16/...] [-wt Byte/Int16]
    [-srcnodata "value [value...]"] [-dstnodata "value [value...]"] -dstalpha
    [-r resampling_method] [-wm memory_in_mb] [-multi] [-q]
    [-cutline datasource] [-cl layer] [-cwhere expression]
    [-csql statement] [-cblend dist_in_pixels] [-crop_to_cutline]
    [-of format] [-co "NAME=VALUE"]* [-overwrite]
    [-nomd] [-cvmd meta_conflict_value] [-setci] [-oo NAME=VALUE]*
    [-doo NAME=VALUE]*
    srcfile* dstfile

What is the problem?

Interestingly, if I remove the "-r cubic" part like so:

"C:/gdalwin32-1.4.1/bin/gdalwarp.exe" -s_srs EPSG:4326 -t_srs "+proj=aeqd +datum=WGS84 +lat_0=40.81266 +lon_0=14.414252" -of GTiff "C:/vesuvius_wgs84.tif" "C:/vesuvius_cubic_aeqd.tif"

everything works correctly, and vesuvius_cubic_aeqd.tif file is created. To make it more strange, I tried replacing the "-r cubic" with "-r bilinear" or "-r average", but again neither of these worked. I also tried, removing the "-of GTiff", and that did not work either.

What am I doing wrong in the upper gdalwarp command syntax?

closed as off-topic by Andre Silva, nmtoken, Jochen Schwarze, xunilk, LaughU Feb 25 at 7:48

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Andre Silva, nmtoken, Jochen Schwarze, xunilk, LaughU
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I just ran it on my OSGeo4W 64-bit based GDAL, and it worked with "-r cubic". Have you tried a different installation? – Mikkel Lydholm Rasmussen Apr 5 '16 at 12:06
  • 1
    Thank you for the help @MikkelLydholmRasmussen. Indeed I tried a newer version: gdal 1.6 (download.osgeo.org/gdal/win32/1.6/gdalwin32exe160.zip) after your suggestion, and it worked! How can I label your reply as the one that solved the problem? – marco Apr 5 '16 at 12:29
  • 1
    Don't update from eight years old version to a six and a half years old version. Get a maintained 1.11 or 2.0 version from gisinternals.com or through OSGeo4W. – user30184 Apr 5 '16 at 12:32
  • Thank for the reply. The reason why I am downloading from: download.osgeo.org/gdal/win32 is because it contains all the necessary files in their respective folders. When I download the Gisinternals.com .zip file, I need to somehow copy some of the content from one folder to the other, in order for the "gdalwarp.exe" to work. Most of the time I do not know which files I need to copy. Can you recommend the link at OSGeo4W? – marco Apr 5 '16 at 12:38
  • 1
    If you double click sdkshell.bat you will on the screen Setting environment for using the GDAL and MapServer tools. WARNING: If you encounter problems with missing oci libraries then type: SDKShell hideoci. So type SDKShell hideoci It will re-run the batch file with parameter "hideoci". Open the bat with text editor and you can see what happens then. It begins with if "%2"=="hideoci" goto hideoci. – user30184 Apr 5 '16 at 18:25