I created a model and added "Iterator Feature Classes" and "Clip". I run the tool and everything works.

But when I save the model and restart ArcMap the tool gets broken. I can't open the "Clip" tool inside the model any more. Look at this image, it's a visual representation of how the tool looks like when I restarted ArcMap.

Visual representation of broken tool in model builder

  • 1
    I experienced the same problem in ArcGis 10.4. Esri responded upon request that it might be associated with German language settings. However, I was not able to resolve the problem. Do you also have German language settings on your computer?
    – user71453
    Apr 18 '16 at 13:09
  • Hi guest, no but i might have some similar codec as I have the Swedish language set.
    – esset
    Apr 22 '16 at 11:06

This problem often occurs here, what "helps" in most cases are these steps:

  • Click on: Validate entire model
  • Go to "Diagram Properties" -> "Symbology" and switch to Style 2. Click on "Accept" and "OK" - Sometimes repeat with switching to Style 1.

If your input is shapefiles then your iterate Feature Classes won't work. Make sure you export your shapefiles into geodatabase feature classes first. Model builder does not like shapefiles! I would also create or use an existing geodatabase for the outputs in this model.

Secondly, just delete the parts from the model that appear broken and add them back in.

Third, make sure the path names are all updated in your model to the most current locations.

Another thing to consider is to utilize the "%" symbols around the output names when iterating so it will create a unique name for each output file. This is called inline variable substitution. Here is a LINK to more info on this.

  • Iam not used to work with geodatabases, only pure shapefiles. Is there another tool instead of "iterate" that handles shapefiles? Cause the model iam about to build will be a big model so deleting and readding isnt an option. Is this a known bug btw?
    – esset
    Apr 7 '16 at 13:59
  • Working with geodatabases is easier than you may think. You can create a new file geodatabase in ArcCatalog. Then you will export your shapefiles into this geodatabase as feature classes by right clicking on your shapefiles in ArcCatalog > export to feature class. If this model will be larger then I highly suggest you convert the shapefiles to feature classes. Shapefiles are very limited in processing capabilities and bugs can often occur when running models. You also do not have to worry about deleting the clip tool from your model and adding it again. Try this out!
    – Goldring
    Apr 7 '16 at 14:12

I also had this problem, my model went ´corrupt´ like this. I resolved this issue by opening another model in a different unaffected toolbox, all models in the ´corrupted´ toolbox were affected by this graphic glitch. When I opened a model which wasn´t located in the affected toolbox, the corrupted models went back to normal when opened after I opened the unaffected model.


Its a bug in 10.4. All my old models went white as picture above after upgrading to 10.4. When i change language settings (Regional and Language Options) from Swedish to English(US) they work. Or i can keep Swedish as language but change decimal sign from , to . (in the Additional settings dialogue).

ArcGIS 10.4 for Desktop ModelBuilder Regional Language Display Patch enter image description here


Blockquote Its a bug in 10.4. All my old models went white as picture above after upgrading to 10.4.

It's indeed a pretty bad bug, ESRI fortunately released patches for 10.4 and 10.4.1 that you can download here:

10.4.1: http://support.esri.com/Products/Desktop/arcgis-desktop/arcmap/10-4-1#downloads?id=7384

10.4: http://support.esri.com/Products/Desktop/arcgis-desktop/arcmap/10-4-1#downloads?id=6421

My Dutch local system worked fine after applying the fix to ArcGIS 10.4.1.

Not the answer you're looking for? Browse other questions tagged or ask your own question.