4

We have FME2016 and an ArcGIS 10.3.1. I am trying to run a task in task scheduler that writes to either a file geodatabase or an ArcSDE enterprise database. This has been successful until about 2 weeks ago when the ArcGIS license manager was updated to ArGIS 10.3.1. from 10.2.1. and FME started showing the following messages in all of the FME log files during a task scheduler run: "The Esri Product license used by this machine does not include licenses for the 'Engine Enterprise Geodatabase' licensing level The Esri Product license used by this machine does not include licenses for the 'ArcInfo' licensing level The Esri Product license used by this machine does not include licenses for the 'Engine' licensing level |ERROR |Unable to perform licensing related tasks. Please ensure that ArcGIS is correctly installed." The ArcGIS Administrator does show that licenses are available and is pointing to the correct license manager. The task scheduler settings are set to 'Run with highest privileges'.
We are thinking this has something to do with permissions settings in task scheduler because the same FME workbenches run successfully when the application is open and manually run. Attached is a screenshot of the task scheduler settings. enter image description here Has anyone else run into a similar issue?

  • Find out what user account the workbench runs under, then start the workbench interactively by choosing "Run-As" and see what happens. sevenforums.com/tutorials/419-run-different-user.html – Kirk Kuykendall Apr 7 '16 at 15:47
  • Thank you for the suggestion. Right now the workbench runs fine if I open the FME application and hit 'run' while logged in with my windows login, which is the same settings set for the task scheduler. I've also tried setting task scheduler with a windows admin account, no luck. Right now we are looking in to getting FME server to schedule tasks, but it would be great to find a solution with task scheduler. – ASM Apr 12 '16 at 14:57
  • 1
    UPDATE: FME support staff figured this out for us. We had to add a new environmental variable (through Windows system settings) as 'ARCGIS_LICENSE_FILE' and set its variable value to (port)@(host) of our license manager. – ASM Apr 12 '16 at 21:25
  • Go ahead and provide this as an answer your own question so that people with the same question can more easily find an answer. – Kirk Kuykendall Apr 12 '16 at 21:50
  • Almost there, click the checkmark to accept the answer. Yes, I know, it does seem a bit vain, but it really is for the good of the community. – Kirk Kuykendall Apr 13 '16 at 16:12
3

Ensure the Windows advanced system settings on a local client (not on the server side) has an environmental variable named 'ARCGIS_LICENSE_FILE' and is set to (port)@(host) of the server that has the installed ESRI license manager.
This is also documented here: http://resources.arcgis.com/en/help/install-guides/license-manager/10.1/index.html#/Defining_port_host_to_one_or_more_license_servers/00790000000t000000/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.