2

I am trying to access a WMTS using this URL from ArcMap 10.3. I was able to get the list of layers (see picture below), and the service is shown in the Catalog Window.

Anyway, when I try to import it (by clicking and dragging a layer into the Table Of Contents), ArcMap always crashes. This seems not to happen with ArcGIS Pro and other GIS softwares (e.g. QGIS), while ArcMap 10.4 crashes as well. As far as I know, the WMTS I am trying to access is a static .xml file, which is not necessarily following the OGC standards. So the main problem could be some non-standardized lines in the xml, but this is just a guess, as I am not an expert of such services.

So I am asking if from the link I provided someone is able to understand what could be the reason of the problem (e.g. some non-standardized lines that show evident errors of interoperability), or at least if the problem occurs also on other machines other mine.

I eventually add that the Tile Matrix Sets shows two "subgroups" (see the picture):

  • GoogleMapsCompatible
  • WGS84

enter image description here

1

I was able to reproduce this at ArcGIS 10.4.1 for Desktop.

I started ArcMap.

Used Add Data to add a GIS Server (of type WMTS).

I could see the layers listed and when I tried to add the first one ArcMap encountered a Serious Application Error.

I am glad that you reported this to your local Esri support and got Bug BUG-000095572 - Adding a specific Web Map Tile Service (WMTS) crashes ArcMap with a serious application error. logged.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.