2

I have to upgrade an application from ArcObjects 9.3 (C# .NET) to 10. Unfortunately, there seems to be some incompatibility regarding the IRasterDataset.Copy method. The following code worked fine in 9.3:

my_raster_dataset.Copy("my_copied_raster", my_sde_workspace);

my_raster_dataset is a raster dataset called "INPUT_RASTER" loaded from a file geodatabase. my_sde_workspace is an ArcSDE 9.3 geodatabase running on SQL Server 2005.

Using ArcObjects 10, I get the following error message: System.Runtime.InteropServices.COMException: The table was not found. [VAT_INPUT_RASTER] at ESRI.ArcGIS.Geodatabase.IRasterDataset.Copy(String copyName, IWorkspace copyWorkspace)

Any ideas or suggestions? Do I have to upgrade ArcSDE to 10 to make this work?

Thanks in advance.

EDIT - Found the answer

Found the problem. I was checking out esriLicenseProductCodeEngine instead of esriLicenseProductCodeEngineGeoDB. Strange, that the code worked with ArcObjects 9.3 since 2010 and suddenly stopped working with ArcObjects 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.