11

Within my ArcMap project (10.2.2) I've got a polygon feature class showing soil types. They are styled using a representation and additionally show the number of the soil type from my attribute table. This is what the legend looks like:

enter image description here

Is there a way to design the legend so the numbers are layed upon the colored polygons as shown in the following picture?

Preferably whitout converting to graphics or any other manual rework.

enter image description here

15

I have managed this earlier by following this workflow:

  1. Double-click the Legend in the Layout.
  2. Legend Properties > Items tab.
  3. Select the layer in the list and click the Style button.
  4. Click the Properties button.
  5. Go to the General tab and click Label Symbol.
  6. Click the Edit Symbol button.
  7. Then use the X and Y offset values to move the labels to the left - for instance, for X -30.

enter image description here

This basically moves the label to the left so it ends up being shown on top of the rectangles.

6

You need to workaround this using the following:

  1. Duplicate the original legend to a have a copy of it.

  2. Double click the original legend go to items -> double click the target layer -> General -> Appearance make sure all labels are unchecked. If you want to show the Layer label of the original legend, you need to do the same for the copied one.

  3. Double Click the copied legend go to items -> double click the target layer (the copy) -> Arrangement and choose the second option which starts with label -> General -> Under Appearance check Show Labels.

  4. Go to layout tab and set the width and height of Symbol to 0.001 as shown below

enter image description here

  1. You may need to adjust the "Vertical patch gap"

  2. Select both the original and copied legends and align center and top, then you will have what you are looking for. Here is the output

enter image description here

  • Are you able to post the image that will be produced when following your workflow? It doesn't work for me as I don't get any symbols shown at all. – Alex Tereshenkov Apr 11 '16 at 8:55
  • I added an image of the final output. – ahmadhanb Apr 11 '16 at 9:00
  • Ok, I got it now. You create a copy of the legend with no symbols showing, so you have two legends - one shows the labels only (with no symbols) and another one only the symbols. – Alex Tereshenkov Apr 11 '16 at 9:04
  • Yes, it's true. – ahmadhanb Apr 11 '16 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.