5

Every time I close QGIS, I get an error message like this:

minidump written to C:\Users\name\AppData\Local\Temp\qgis-20160412-100443-7416-5376-ea85bef.dmp

This happened also in the former versions, and reappears when installing the new one (i.e. delete the complete OsGEO4W64 file and new installation). It still remains when I deactivate all plugins. What can be the reason?

  • 1
    Did you run QGIS with --noplugins? Plugins can still crash QGIS when loaded but deactivated. – Matthias Kuhn Apr 12 '16 at 8:20
  • 3
    For a clean reinstall, also delete the C:\Users\name\.qgis2 folder. Some settings are stored there. – AndreJ Apr 12 '16 at 9:45
  • thank you, last was the right hint !! After deleting this folder the problem was gone... – oppia04 Apr 27 '16 at 16:10
6

Just trying to make it more visible. As @AndreJ answer in the comments. The solution for me too was deleting the folder:

C:\Users\'PC-NAME'\.qgis2
2

Sorry, this solution does not work for me.

Had a working version of 2.14.2 under Windows 7 32-bit, but unwisely upgraded to 2.14.6 LTR. Programme would load, but crashed on all but the simplest of projects with a similar minidump error as above. Have had the same issue in 2.16.

Tried removing .qgis2 folder with no effect.

Tried deselecting plugins to see if that would help. No effect.

Removed 2.14.6, then legacy 2.14.2 developed the same issue: crashing every time.

Problem project includes Openlayers plugin (but not selected at the time), georeferenced TIFFs, heatmaps, a range of raster base maps in OSGB36, and Natural Earth vector layers in WGS84. Because I cannot get the project to load, I cannot test if plugins are the cause. The option to upgrade plugins is greyed out.

Removed all versions of QGIS and orphan folders in C:/Program File, and have reverted to 2.12.2 This works for now.

0

The "Spatial Bookmarks" window was the culprit of my crashes. My QGIS 2.18.15 install crashed every time on exit and it only started after I installed the "Semi-automatic Classification Plugin" (SCP). However it continued long after I uninstalled it via the Plugins/Manage & Install.

I reinstalled Q several times with various levels of manual cleanup (folders and registry). Each time I opened Q for the first time all would work fine, but as soon as I started configuring my interface/plugins it happened again. I finally traced it down to the "Spatial Bookmarks" window being enabled, whether it was docked or not.

It's odd that I used "Spatial Bookmarks" for a while with no problems until the SCP was installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.