I do not understand why my add-in toolbar and button shows up as "Missing" when I open ArcMap. I am not sure whether this is an issue with ArcMap 10.3 or whether I did anything wrong. Have anyone ever encountered this before?

enter image description here

  • maybe it is because of the version 10.1 and 10.3. I am not sure. Whatever add-in I create on this computer will show up as "missing". But I found that creating the add-in on a different desktop solves the problem.
    – Wenwei Xu
    Commented Apr 13, 2016 at 23:39
  • I saw this a few weeks ago and believe it was version related. Commented Apr 13, 2016 at 23:49

4 Answers 4


Usually I see this if the Windows environmental variables aren't set up correctly.


  • Start command prompt (go to Start Menu ---> Run ---> type cmd)
  • Type python, and then import arcpy (shown below is what you want to see)

Does everything work without errors?

enter image description here

If you get an error, then try:

  • Right click on My Computer and go to Properties, then click on the Advanced system settings, and then on the Advanced tab click on the Environment Variables button at the bottom.

  • Next, in the lower part of the window find the Variable that says Path and double click on it, and makes sure that the following paths are at the front of the Variable value list:


(Verify that these paths exist. Also, be sure to alter the 10.2 to your ArcGIS version.)

  • Restart your computer. After restarting, try doing the python and import arcpy from the Command Prompt again.

enter image description here

Otherwise, it may be version related like @Chad Cooper suggested. This is pretty easy to fix. Open the .esriaddin file with 7zip, and then open the config.xml file.

enter image description here

In the config.xml file look for:

<Target name="Desktop" version="10.1" />

Change the version to match your current install. Save the edits to the config.xml file, and when it prompts if you'd like to update it in the archive, click OK.


I have seen this in the past - happened on half of our work PCs one day and we never did find the cause, however we did find a work-around.

Instead of loading our add-ins into the default location (My Documents I think) we set up Additional Add-In folders in ArcMap and copied our Add-In files there, and they work fine. We didn't have to put all add-ins there, we found most worked, but the few that didn't worked fine with this work-around.

Open Add-In Manager from the Customize menu

enter image description here

Click the Options tab and Add Folder to point ArcMap at an alternative source for Add-In files.

enter image description here

For any Add-Ins that don't work, just find the esri-addin file and copy it into that new location. I don't recall if the old one in My Documents had to be removed first, but that's an easy delete out of My Docs to get rid of it if required.

This even worked for Add-Ins that came with an installer that installed other files elsewhere - only the Add-In needed to be placed in the new folder, everything else still worked fine.


That happened with me because I wrote import mapping, which causes the error - there is no module called mapping


Some time ago I think this issue had something to do with 'spaces' in the path name - e.g. this caused a problem 'c:\arcgis\add in\' while this didn't cause a problem 'c:\arcgis\add_in\'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.