1

I have a KML file that I know for a fact has 400 some points in it. But every single time I try to convert it using the toolbox conversion tool, it keeps ending with this result:

ERROR 000401:No features were found for processing

I have tried this on two different computers so far, and I have opened it with Google Earth both times to verify that the file does have the points.

Not sure what to do next, does anyone have any other things I could try besides this conversion tool?

I am using ArcCatalog 10.4.

1
  • What created the KML? May be it is malformed and simply won't import?
    – Hornbydd
    Apr 16 '16 at 14:25
2

Could you check ArcGIS help, which stated that

This warning commonly occurs when the Extent or XYDomain environment settings have been previously set for a specific geographic area and the values were inadvertently used when running another tool.

2
  • I do not think this is relevant since KML conversion is a bit different, i.e., there is no output location specified before reading the KML. Even though I tested various options to those parameters, in KML conversion I did not succeed.
    – fatih_dur
    Nov 20 '20 at 3:32
  • Most probably this subsequent part of the help is more relevant A query returning zero features is valid but will result in no features in the layer being used by a tool. The tool cannot read KML geometries and returns zero feature.
    – fatih_dur
    Nov 20 '20 at 4:16
1

One quick and easy workaround that worked for me is this:

Open the KML file in Google Earth. Create a new folder under 'My Locations'. Expand the KML so you can see all the features. Select all the features and drag them in to the new folder. Right click on the new folder (that now contains all the features that were previously in the KML file) and 'Save Place As' to create a new KML file that you can then convert to a layer in ArcGIS.

This might not work in all situations, but it solved this error for me with a KML made up of points.

0

This problem might be related to the unsupported tag generated by Google Maps. More specifically CascadingStyle is the problem, e.g., <gx:CascadingStyle kml:id="__managed_style_284.....">. In another answer to similar problem, https://gis.stackexchange.com/a/367696/28687, there was a suggestion.

My solution was to remove all those tags manually by Find/Replace from KML.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.