If my problem is that my ID types are not the same, I need help in addressing that. I started with an excel file, I read that on a mac to I need to save that as a Windows comma Separated file. I did.

QGIS 2.14 Add Layer - Add Delimited Text Layer - Adding Layer


the csv file has

  • parcel_num as text
  • situs_cmptaddr_number as text
  • acres as double

After join the Shp file has

  • PARCEL_NUM as string
  • situs_cmptaddr_number as text
  • acres as double

I have tried loading the csv file as a vector layer with a like named .csvt file but it did not pick the the details in the csvt file.

I am new to QGIS.

My file names are --- mailingList_w_csv.csv and mailingList_w_csv.csvt.

I am using a mac. I have since used a PC to create the csv file from an excel file. the csvt file is being edited on my mac

The csvt file looks like this - “String”,”Text”,”Double”

  • Add Delimited Text Layer does not evaluate csvt files. (csvt files are only used by Add Vector Layer.) Is there a screenshot #3 missing in the question? Can you share test data?
    – underdark
    Commented Apr 16, 2016 at 14:19
  • Afaik, "Text" is not a valid option in csvt according to gdal.org/drv_csv.html. The whole csvt will be ignored if there is an error in it.
    – underdark
    Commented Apr 17, 2016 at 6:52

1 Answer 1


I found the answer !! Download Open Office. Open the CSV file as a text document in Open Office. Then save as a dbf file. Then add new Vector Layer with the dbf file. Worked beautifully. I lost the link to the helpful article. There was just one sentence on this topic, which is summarized above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.