2

We have a service with a feature class and two related tables. All three have attachments. It's complicated, but it works fine when used online in Collector. When we download it for disconnected editing to a iPad 2 or iPhone 5s, it will open offline. However, when we try to add a new entry collector shuts down with no error message. This happens every time. I've tried republishing the service, uninstalling and reinstalling collector. Then I tested it on a fairly old and dumb Samsung tablet, and it worked fine. The tablet has an older version of collector; I'm not sure if that has anything to do with the problem. Has anyone else experienced this problem?

  • can you update the Samsung tablet with the newer version of Collector to test? – Midavalo Apr 16 '16 at 18:46
  • This is a worry. Please update on outcome – FelixIP Apr 16 '16 at 21:32
  • Well no, because if that's the problem I wouldn't have anything that works. The version on the Samsung is 10.3.7. On the iOS devices I have 10.3.9. – Jeri Ledbetter Apr 17 '16 at 5:13
1

I spent some quality time with ESRI tech support. We ended up creating a map package, exporting it to an xml document, and creating a new geodatabase from that. Then I started all over again with a new mxd document and exported it to a new map. Then I could get it to work with an IOS and offline editing. Today we added some python code (which we had done with the other geodatabase) to update a value, and it quit working again. Is it possible that the python code could have been the problem?

  • What value is it updating? Is it altering the schema of a layer? – Russ Roberts Apr 26 '16 at 14:51
  • It was updating a value on the feature class that counted the number of entries to a table. We started all over again as before, rebuilt the geodatabase, published the service, and rebuilt the map. It's working now with the python code running. So that wasn't the problem. It appears to be related to very minor schema changes like populating a domain. Or something. My take-home message is, if it's working stop messing with it. – Jeri Ledbetter Apr 30 '16 at 17:19
-1

Disclaimer - this may be specific to my case.

I was experiencing the same issue, where Collector would shut down when adding new data to the related table. I had built a second, (almost) duplicate app which worked. Digging into the service definition at the REST, I found that the non-working version has the following snippet:

enter image description here

Upon removing the "ownershipBasedAccessControlForFeatures" object and properties and updating the service definition, the Collector app worked. I made sure to create a copy of the original service definition just in case I broke everything!

  • Please always provide code as text rather than pictures. – PolyGeo May 17 '18 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.