2

I have 6 images from Landsat 8 (Green,Red,NIR,SWIR1,SWIR2,NDVI). When I want to layerstack them with "Merge" I always get a result tif which is just black and white, however I can see that all 6 bands contain values. When I save them with "Virtual Raster" and the option "Seperate" i get the result I want. But when I want to save the virtual raster with "Save as" Gtiff I get just a data which contains 0 KB. Anyone has a idea how to fix this?layerstack black and white Virtual Raster

  • You should include the GIS software you are using (ideally with version number). It sounds like you are using QGIS but we cannot be certain unless you include this information. – Kersten Apr 17 '16 at 14:51
  • Yeah what software are you using ? – PROBERT Apr 17 '16 at 15:08
  • Sorry, I'm using QGIS 2.14 Essen. I tried it again with merge and it worked. I saved the outputs on a USB flash drive before. Now I created a folder on my Desktop and it worked. Can it cause problems if you save outputs directly to a USB flash drive? – remotesatellite Apr 17 '16 at 17:14
  • It should work however always remember to backup before what you do because otherwise if you didn't then if it got corrupt and then you would have to do all over again... – PROBERT Apr 17 '16 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.