3

i am using ArcGIS 10.4 for Desktop and when i try loading my shapefiles into the arcmaps it shows extra incorrect lines in my polygon shapefile is there anyway to fix this inconsistencies automatically?

I tried using the topology tools and snap tool but it didn't fix the issue.

this image shows the extra incorrect lines going through the polygons

this is how the data was before being converted to a line this is the image of the dots before being converted to lines

  • Have you tried to Repair Geometry? I won't guarantee that will fix it but it is something that will be quick for you to try before asking you for more details. – PolyGeo Apr 19 '16 at 22:25
  • yes i did, by the way the geometry data i got it from a website could it be that the the data itself is wrong ? – Abdullah Apr 19 '16 at 22:40
  • That is what I suspect. Is what you see displayed consistent with what you see when you Start Editing polygons in a layer sourcing that shapefile? If it is, then I would go back to the data provider to try and learn more about how it was captured and any data conversions that have occurred before it reached you. – PolyGeo Apr 19 '16 at 22:53
  • yes when i start editing the polygons they are the same as the ones displayed – Abdullah Apr 19 '16 at 23:17
  • For a dataset to be a shapefile, it needs to conform to the specification. It appears that you have data which is non-conformant. Repair Geometry can only do so much. – Vince Apr 20 '16 at 0:36
1

To properly convert points into lines, you need to have a unique field which has a same value for each group of points so that ArcGIS can recognize that these group of points with a same value represents one line. Without a unique field, the output lines will be mixed lines crossing each other. You refer to the Points To Line help for more information. Please make sure you have a field with a unique value that represents group of points.

  • there is a shared values between groups of points – Abdullah Apr 20 '16 at 10:58
1

The point to line feature in arcgis requires data in a table to be ordered on the id for the group of points, i tried sorting the data but that didn't work still the point to line feature draws extra unnecessary lines but there was less extra liens this time,so my final solution was to use the point2one plugin in QGIS and that worked perfectly no extra liens so i saveed the shape file and imported it into arcgis and everything was good, i guess that the arcgis point to line feature had some kind of problem in finding the groups of point and not stopping drawing when moving from one group of points to another

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.