1

I am trying to import CSV file and get no reported errors but there are no points visible. If I click on "zoom to extent" nothing happens (even if I move away from the location of the points before doing this. I have shut off all raster layers but they were not hiding the points. I have tried to find an answer here but none seem to fit my problem. I have followed the steps in this tutorial: http://www.qgistutorials.com/en/docs/importing_spreadsheets_csv.html

Here is an image of the CSV file:

enter image description here

here is the import dialog box: enter image description here

and here is the QGIS attribute table after import: enter image description here

I am saving in WGS84. I tried the local projection (NAD83 Zone 19N) but that made no difference.

I am using QGIS 2.12.1 on Windows 10. Any suggestions on what I am doing wrong?

  • 1
    WGS84 is definitely wrong because these x and y are not latitude/longitude values. – underdark Apr 21 '16 at 19:39
  • 1
    Most likely some projection problem, Can you set the Nad83 to the layer and turn of the on-the-fly projection (via options-crs). Can you thenzoom to the layer and see them? – Matte Apr 21 '16 at 19:57
  • Have you made sure that there are no other layers overlaying the view? If a raster layer for example would be over the point layer, you can not see the points because they would be physically under the raster image. – Konan Pruiksma Apr 22 '16 at 9:04
1

If the data should be located in Maine, UTM 19N looks rather good:

enter image description here

Otherwise it could be some State Plane coordinate system, depending on the state you are working in.

You might have seen nothing, if you set the CRS wrongly to WGS84 (which is default in QGIS without prompting), and a Google background layer in EPSG:3857. The coordinates are out of range for any reprojection from EPSG:4326 to EPSG:3857. In this case, Set Layer CRS is the right tool to change the wrongly applied CRS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.