-1

I am trying to access a WMS layer from GeoServer installed locally and adding to my Cesium JavaScript application. WMS layer was not being added. I just found from search that it may be due to CORS filter not configured. So I did configuring CORS in /etc/tomcat7/web.xml as below:

enter image description here

Even after configuring, I can't access the WMS from GeoServer. My responses from GeoServer in developer tools is attached as a snapshot.

enter image description here

Did I go wrong somewhere?

  • Please always include code as formatted text rather than as a picture. – PolyGeo Apr 25 '16 at 6:20
  • 1
    You don't need CORS for WMS images to work – Ian Turton Apr 25 '16 at 7:50
1

My assumption are you are using jetty geoserver (installer) and you have your application on tomcat7 which is accessing WMS. In this situation a better solution is to deploy the geoserver war file in tomcat7 . This solves the root problem you won't need CORS at all !

Update :

the problem seems to be in url format check this for more reference http://docs.geoserver.org/2.8.x/en/user/services/wms/reference.html

  • Geoserver is already on the server. – User123 Apr 25 '16 at 6:16
  • 1
    If the application server and geoserver on same server then you don't need CORS. – Abhijit Gujar Apr 25 '16 at 6:47
  • Well. Alright.. – User123 Apr 25 '16 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.