2

Am having an issue with the QGIS Georeferencer - I start with a fresh canvas but for some reason, the points always end up shifting a great amount (see screenshot).

I've double checked my points, and they are all correct - but you can see in the background, the referenced map image is upside down, and mirrored. Is there something I'm doing wrong? I'm converting a project from ArcMap and never experienced an issue like this there so I'm not sure as to where to go to with this problem.

Screenshot

It seems my error starts with 4 or more points, 3 or less and technically the points work but QGIS georeferencer gives out an error stating that it is "not solvable". BUT the points are exactly where they need to be (see below) enter image description here

Whereas, when I click to include the fourth point, which is in no means drastically different or wrong (as I've tried three different locations just to test the 4+ error theory), the georeferencer calculates that the points need to shift thousands of points away (see below) enter image description here

Below is my transformation settings window. One thing to note, after picking the same exact points, with the same exact transformation settings... it all of a sudden works. Not sure why, or how, but I'll take what I can get. Maybe it is something in my settings? (But again, I didn't change anything).

enter image description here

1

Something is way off with your dY values.

If I understand correctly, your image is just a scan from a paper map, but it is for some reason defined with EPSG: 3857. I would suggest resetting the georeferencer, define the image CRS to be the same as you project (4326 in this case) and the proceed to georeference it again.

  • 1
    You can change the CRS inside the georeferencer window under Settings -> Transformation settings, Target SRS. It should always be the same as the project CRS, if you pick your points from the canvas. The residuals should be small, otherwise the result is useless. – AndreJ Apr 26 '16 at 6:24
  • 1
    I've done what you both have suggested, but it appears to be something else, as you'll see in my edited question... unless something like this is normal for this situation that is. – Matthew Apr 26 '16 at 21:11
  • Have you tried opening a new .qgs file and georeferencing it anew? I have to admit that I don't know exactly why this happens. Also. what method are you using to georeference? 1st order? 2nd order? – HDunn Apr 26 '16 at 21:17
  • I just tried to go through a new file and it does the exact same thing. I also made sure to reset the image file by just starting from the beginning with a new file - still nothing. And I know, quite the pain. To be honest though, I'm not sure what you mean by the method, just give me a hint and I should be able to answer it, still getting used to QGIS. Out of curiosity, would it be at all helpful to somehow share the files? – Matthew Apr 27 '16 at 3:44
  • It surely helps if you can share the files. And a picture of your transformation settings window might be helpful too. – AndreJ Apr 27 '16 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.