3

Often when working in QGIS print-composer (2.14 and prior), at a certain point the map content disappears and only the empty map frame remains. This happens mostly after closing and re-opening my project or randomly after I hit the "refresh preview" button.

My solution so far was to just add new mapframes (over and over again) but this is annoying.

What is the reason behind my map-preview disappearing and what to do about it? The screenshot shows the problem and the general adjustment I am using.

screenshot_frame

  • maybe you can try it again, but this time check the option to lock the map layer (kartenelements Layer festhalten).. – Uje Indo Apr 26 '16 at 14:47
  • Have you tried just pressing the "Vorschau aktualisieren" button? – underdark Apr 26 '16 at 18:22
  • @UjeIndo thanks maybe that will help! I'll post an update how it worked. – Vogon_Jeltz Apr 26 '16 at 19:38
  • @underdark - yep, I tried that. :D – Vogon_Jeltz Apr 26 '16 at 19:39
3

I found the reason to be the CRS settings: The project settings are "On The Fly - Transformation" to an UTM projection of my choice. I've realised that somehow QGIS changes the CRS setting from my UTM-Zone to WGS84 after saving, closing and re-opening - don't ask why.
Of course, after the setting is changed to WGS84, the area is not displayed correctly in the mapframe anymore. By simply choosing the correct CRS in the 'properties' -> 'CRS' menu again, the map is correctly displayed in the print composer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.