I change the coordinate system (CRS) of a point data but it disappeared. I tried zooming to layer but its not visible. I am using QGIS 2.14

  • How did you change CRS? You should always change CRS by re-saving the layer. You can do this by right-clicking the layer and using the Save As... option. Or have you already tried this?
    – Joseph
    Apr 27, 2016 at 9:23
  • what did you change it from to?
    – Ian Turton
    Apr 27, 2016 at 9:31
  • This has happened to me a couple of times too. I believe some CRS interpret other CRS's values as literally off the charts resulting in them not being plotted anywhere. The feature remains snugly in the attribute table though, ready to be restored to the map using the correct CRS.
    – Henrik
    Mar 9, 2017 at 7:59

1 Answer 1


The correct way to change your CRS is to save the layer. Try the 'on the fly' transformation. Project>project properties> CRS> check the 'on the fly' transformation.

Tip: use always your default projection

  • "The correct way to change your CRS is to save the layer." - so why there is promising option "set layer CRS"? :)
    – Line
    Feb 8, 2018 at 11:11
  • @Line if your layer has a wrong projection assingned, you can correct it with "Set layer CRS".
    – AndreJ
    Aug 5, 2019 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.