1

To solve Rendering features based on relationships using ArcGIS for Server?, we created a view in the database that joins the two tables together. That works fine. I see the feature class in ArcCatalog and can view the features in the preview window. But when I try to add the feature class in ArcMap, nothing happens (ArcMap seems to be working for a few seconds but nothing changes) - and no error message either. Is there something that needs to be done so that I can add it to a map?

We created the view as a simple join between the two tables, selecting the shape from the feature class and some attributes from the table. When viewing the class in ArcCatalog it's called feature-class instead of sde-feature-class, but the option to register the class with the geodatabase is greyed out.

We're using Oracle as our DBMS and the view is defined as follows (note that I simplified my context; as such, the names of the attributes in the SQL are not the same as in the screenshot but only differ in name):

SELECT a.statusinfo, b.objectid, b.shape, a.workpackage, a.objectid as status_oid
FROM statustable a, buildingtable b
WHERE a.refobject = b.objectid AND a.buildingclass = 'specificbuilding'
    AND a.statusinfo IS NOT NULL
ORDER BY b.objectid

This is what the feature class looks like in ArcCatalog:

Properties of feature class in ArcCatalog

And this is what the context menu looks like: context menu of feature class

Sorry for using a german interface, I don't have a environment with english culture settings right now.

  • 1
    Could you post some details about the particular database backend you are using? Also, perhaps the sql from the view that was created, and a screenshot of what you see in ArcCatalog would help visualize the actual problem. There are a number of areas that might be having issues, so the more detail you can provide, the better. Also, what projection is your data in? Does the view that was created have a unique ID field? – Get Spatial Apr 28 '16 at 23:11
  • @GetSpatial Thanks for the comment, I updated the question with additional information. – germi Apr 29 '16 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.