I went to step 4 from How to install LAStools toolbox in QGIS guide and extracted LAStools to my C drive and just made the folder there.

I can't do step 8 because it seems to already be in "advanced interface". Then, step 9 mine only says "Options".

Step 10 is where I get the error message and it won't go past that step. I keep getting this error message. Can anyone help me get this installed? Error Msg

  • rapidlasso.com/2013/09/29/… is there a difference on your setup?
    – Mapperz
    Commented Apr 28, 2016 at 18:02
  • To start I went to step 4 and extracted LAStools to my C drive and just made the folder there. I can't do step 8 because it seems to already be in "advanced interface". Then step 9 mine only says "Options". Step ten is where I get the error message and it won't go past that step.In the other question the user gets the toolbox to show up. I can't even get the tool box to add. So I don't have the freezing problem since it won't even show the tool box. Commented Apr 28, 2016 at 18:52

7 Answers 7


According to Diego Alonso's comments from the mappingGIS blog1, this error is related to QGIS version 2.14. With the upgrade, the standalone installer eliminated the msys folder from GRASS 7 algorithms.

To bypass this error, go to Processing -> Options -> Provider and deactivate all GRASS folders from previous versions. Set these paths as blanks. Then, activate GRASS 7 and fill in GRASS7 folder field with its corresponding path.

enter image description here

1. Alonso, D. Cómo configurar LAStools en QGIS para manejar datos LiDAR. mappingGIS blog. Post from 8th, April, 2015.

  • I have added an empty folder and now it is working. but what does Msys folder do?
    – Mike
    Commented Feb 28, 2018 at 6:46

2.18 user here - After many hours of trying to get the LAStools product functional I finally found this solution to the \msys error - namely to simply add the folder as suggested here - works BUT I then received a similar error in regards to Saga, and a similar solution worked too. So, the problem seems to be that these pathways were not updated with the releases, and, I guess, with future releases I'll have to go to the file directory and update accordingly. But at least I got it working now! thanks.

  • After fixing the GRASS pointer, I got a similar message about the R folder, but was able to change the pointer from the 2.14 path to the 2.18 path, and it started working.
    – bwilkes
    Commented Mar 26, 2018 at 16:03

I added empty folder "Mysys" in the path and it worked...


It's 2018 with the new QGIS 3 I had this issue with GRASS Folder.

I just had to repoint the GRASS folder and GRASS Docs folder to the right directories as shown in the screenshot. enter image description here


Hopefully this may be of some value to QGIS 2.14+ users trying to install LAStools. The "Processing > Options > Providers > Tools for LiDAR data" dialog does work, but it takes a bit of a kabuki dance to do it. Clicking on the "LAStools folder" text string itself doesn't work as you would expect, but if you double click on the text string, THEN click in the white space to the right of the string, you should finally come up with a dialog that lets you specify where you put the LAStools folder:

LAStools folder location

It may take a different kabuki dance for you, but eventually the dialog will appear. The same would probably hold true for issues with SAGA and GRASS, but I haven't tried activating those.


I got the same error as described in the initial post.

To expand a bit on the post that suggested adding a directory "msys" into the file path.

I first created a new directory in C:\QGIS Essen\apps\ named msys. I then copied the LAStools folder into the new directory.

I then completed step 10 without issue.

The LAStools appeared in the processing toolbox.


Update post 3.0 there is no laz support. Install 2.18 and make the msys folder blank while also making sure all grass 7 file paths are correct. Then go back into enable additional provides and activate Tools for LiDAR and double click beside folder to add a path to LASTools (before the bin) and it should activate.

Not the answer you're looking for? Browse other questions tagged or ask your own question.