26

I'm having trouble installing QGIS on Xenial.

`debian` release

When I try using the debian release (i.e. without ubuntugis dependencies) I get the following errors (please note there is no xenial release so I've used wily when setting up the sources.list):

~$ sudo apt install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 python-qgis : Depends: python-qgis-common (= 1:2.14.1+23wily) but it is not going to be installed
               Depends: libqgispython2.14.1 but it is not going to be installed
               Depends: libqgis-analysis2.14.1 but it is not going to be installed
               Depends: libqgis-core2.14.1 but it is not going to be installed
               Depends: libqgis-gui2.14.1 but it is not going to be installed
               Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
               Depends: libqgis-server2.14.1 but it is not going to be installed
 qgis : Depends: libgdal.so.1-1.11.2 but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        Depends: libqgis-analysis2.14.1 but it is not going to be installed
        Depends: libqgis-app2.14.1 but it is not going to be installed
        Depends: libqgis-core2.14.1 but it is not going to be installed
        Depends: libqgis-gui2.14.1 but it is not going to be installed
        Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
        Depends: qgis-providers (= 1:2.14.1+23wily) but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.1+23wily) but it is not going to be installed
                     Depends: libqgis-app2.14.1 but it is not going to be installed
                     Depends: libqgis-core2.14.1 but it is not going to be installed
                     Depends: libqgis-gui2.14.1 but it is not going to be installed
                     Depends: libqgisgrass7-2.14.1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

`ubuntugis` release

After failing with the debian release I've tried the ubuntugis release by adding the ubuntugis-unstable PPA (again I used the wily release of ubuntugis for consistency with the QGIS release):

:~$ sudo apt update 
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [92.2 kB]
Hit:2 http://gb.archive.ubuntu.com/ubuntu xenial InRelease                                                                                                
Get:3 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily InRelease [15.5 kB]                                                                     
Get:4 http://gb.archive.ubuntu.com/ubuntu xenial-updates InRelease [93.3 kB]                                                                                    
Hit:5 http://ppa.launchpad.net/git-core/ppa/ubuntu xenial InRelease                                                                                             
Hit:6 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease                                                                                   
Hit:7 http://gb.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                        
Get:8 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily/main amd64 Packages [4,297 B]                       
Get:9 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily/main i386 Packages [4,307 B]                  
Get:10 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily/main Translation-en [2,463 B]     
Ign:11 http://linux.dropbox.com/ubuntu wily InRelease                                                  
Hit:12 http://linux.dropbox.com/ubuntu wily Release                      
Ign:14 https://cloud.r-project.org/bin/linux/ubuntu xenial/ InRelease
Hit:15 https://cloud.r-project.org/bin/linux/ubuntu xenial/ Release
Ign:17 http://qgis.org/ubuntugis wily InRelease    
Err:18 http://qgis.org/ubuntugis wily Release
  404  Not Found [IP: 104.27.138.220 80]
Reading package lists... Done
W: https://cloud.r-project.org/bin/linux/ubuntu/xenial/Release.gpg: Signature by key E298A3A825C0D65DFD57CBB651716619E084DAB9 uses weak digest algorithm (SHA1)
E: The repository 'http://qgis.org/ubuntugis wily Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

The line E: The repository 'http://qgis.org/ubuntugis wily Release' does not have a Release file. looked pretty fatal so I tried trusty (the most recent supported release). This updated, but when trying to install:

:~$ sudo apt install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 python-qgis : Depends: python-qgis-common (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
               Depends: libqgispython2.14.1 but it is not going to be installed
               Depends: libqgis-analysis2.14.1 but it is not going to be installed
               Depends: libqgis-core2.14.1 but it is not going to be installed
               Depends: libqgis-gui2.14.1 but it is not going to be installed
               Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
               Depends: libqgis-server2.14.1 but it is not going to be installed
 qgis : Depends: libgdal.so.1-1.11.2
        Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
        Depends: libgeos-c1 (>= 3.4.2) but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        Depends: libqgis-analysis2.14.1 but it is not going to be installed
        Depends: libqgis-app2.14.1 but it is not going to be installed
        Depends: libqgis-core2.14.1 but it is not going to be installed
        Depends: libqgis-gui2.14.1 but it is not going to be installed
        Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
        Depends: qgis-providers (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
                     Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
                     Depends: libqgis-app2.14.1 but it is not going to be installed
                     Depends: libqgis-core2.14.1 but it is not going to be installed
                     Depends: libqgis-gui2.14.1 but it is not going to be installed
                     Depends: libqgisgrass7-2.14.1 but it is not going to be installed
                     Depends: grass-core but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Finally, for the sake of completeness, with the xenial release of ubuntugis:

$ sudo apt install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 python-qgis : Depends: python-qgis-common (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
               Depends: libqgispython2.14.1 but it is not going to be installed
               Depends: libqgis-analysis2.14.1 but it is not going to be installed
               Depends: libqgis-core2.14.1 but it is not going to be installed
               Depends: libqgis-gui2.14.1 but it is not going to be installed
               Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
               Depends: libqgis-server2.14.1 but it is not going to be installed
 qgis : Depends: libgdal.so.1-1.11.2 but it is not installable
        Depends: libgdal1h (>= 1.8.0) but it is not installable
        Depends: libgeos-c1 (>= 3.4.2) but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        Depends: libqgis-analysis2.14.1 but it is not going to be installed
        Depends: libqgis-app2.14.1 but it is not going to be installed
        Depends: libqgis-core2.14.1 but it is not going to be installed
        Depends: libqgis-gui2.14.1 but it is not going to be installed
        Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
        Depends: qgis-providers (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
                     Depends: libgdal1h (>= 1.8.0) but it is not installable
                     Depends: libqgis-app2.14.1 but it is not going to be installed
                     Depends: libqgis-core2.14.1 but it is not going to be installed
                     Depends: libqgis-gui2.14.1 but it is not going to be installed
                     Depends: libqgisgrass7-2.14.1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hopefully a release of QGIS for Xenial will be made available soon, but has anyone managed to install QGIS 2.14 on Xenial?

35

It looks like there actually is Xenial support in the debian repository and although I haven't tried the following solution myself I guess it is worth a try.

Before trying the following I would uninstall all previous qgis packages using sudo apt-get remove qgis python-qgis qgis-plugin-grass and remove deb http://qgis.org/debian wily main and deb-src http://qgis.org/debian wily main from /etc/apt/sources.list.

EDIT To remove packages that are installed as automatic dependencies when installing qgis, run the command sudo apt-get autoremove after running the above commands to remove them. END EDIT

The following is adapted from qgis.org to include the xenial keyword.

Add the following to your /etc/apt/sources.list :

deb http://qgis.org/debian xenial main

deb-src http://qgis.org/debian xenial main

then execute:

sudo apt-get update

sudo apt-get install qgis python-qgis qgis-plugin-grass

I'm very interested to hear if you get it working.

  • 1
    The one configuration I didn't try! Thank you. – Phil Apr 29 '16 at 11:05
  • Glad to be able to help out! – JonasPedersen Apr 29 '16 at 11:24
  • 2
    This is the solution I used, but it didn't work until I removed a GDAL 2.1 folder from python's dist-packages folder. It was obscuring the correct version and causing the missing python-gdal error. All good now. – Rob Skelly Apr 30 '16 at 6:02
  • for me the download started but there was warning not verified. should i be worried a lot ? – Abhijit Gujar Apr 30 '16 at 12:18
  • 2
    if you run into keyring issues, see this page for instructions.. – Nxaunxau May 1 '16 at 6:56
4

If you are unsure which distributions are supported, enter the url after deb into your browser, and navigate to the dists folder.

Then you see that http://qgis.org/debian/dists/ is up to xenial, while http://qgis.org/ubuntugis/dists/ only supports precise and trusty.

Other sources are the ubuntugis stable ppa, which currently has only QGIS 2.8.3 for trusty, while ubuntugis unstable is still at QGIS 2.8.1. There has been some activity lately on those ppa, so keep an eye on them.

And QGIS 2.14.1 is also available for Debian sid from the main debian packages, while jessie backports offer 2.8.6 (same as for Ubuntu).


UPDATE

The ubuntugis-unstable PPA now supports QGIS 2.14.1 for Xenial too.

3

As a Linux Mint 'Cinnamon' 17.3 user I also struggled with these "unmet dependencies (libgdal.so.1-1.11.2 etc.)" and had to update the ppa. I did this by including the following links in the /etc/apt/sources.list:

deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main
deb-src http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main
  • 1
    Does this work for Ubuntu xenial as well? As far as I see there is no GDAL or QGIS package in that ppa for xenial (yet). – AndreJ May 5 '16 at 6:07
  • Apparently there are no GDAL or QGIS packages for Xenial yet. I don't know to what extent you can use the trusty ones (new to Linux and QGIS) – andschar May 5 '16 at 13:42
  • For Linux Mint 17.3, it is save to use the trusty binaries. The equivalent to ubuntu xenial in the Mint world, Linux Mint 18, will be available by June 2016. You might have to use the QGIS debian packages for it. – AndreJ May 5 '16 at 18:31
  • Here's the official ref in case people are wondering where this is coming from - trac.osgeo.org/ubuntugis/wiki/UbuntuGISRepository – chrismarx Jan 9 '18 at 14:58
  • And yes, it does work now for 16.04 – chrismarx Jan 9 '18 at 15:10
0

To install it in xenial, you only need to:

sudo apt-get update
sudo apt-get install qgis
  • For what it's worth, I have found QGIS 2.16.3 to be unstable in Xubuntu 16.04: frequent crashes (programme shuts down, no warning, no crash report - nothing), often associated with changes in On the Fly re-projections of projects containing raster backdrop mapping. QGIS 2.16.2 is slightly more reliable in Kubuntu 14.04 but not perfect. – NickN Sep 30 '16 at 8:11
  • This won't work without adding an additional ppa though right? – chrismarx Jan 9 '18 at 15:10
  • The OP clearly states they have already tried this. – Dave-Evans Mar 15 '18 at 0:57
0

Despite implementing many tips found on the Internet I couldn't get QGIS to install on Ubuntu 16.04 until I came across this short and helpful video: https://www.youtube.com/watch?v=hmJwYaYmRDU

Until then I was also struggling with messages about various "unmet dependencies" and "missing/broken packages" (hat tip to the video creator: Linux Enthusiast)

Here are the steps you need to follow in the terminal:

Step 1. Type in:

sudo nano /etc/apt/sources.list [press enter]

Step 2. Type in:

deb https://qgis.org/ubuntugis-ltr xenial main

deb-src https://qgis.org/ubuntugis-ltr xenial main    

deb http:/ppa.launchpad.net/ubuntugis-unstable/ubuntu/ubuntu xenial main

[Press Enter, and when prompted to "Save modified buffers", press y key]

Step 3. Type in:

wget -O - https://qgis.org/downloads/qgis-2017.gpg.key | gpg --import [press enter]

Type in:

gpg --fingerprint CAEB3DC3BDF7FB45 [press enter]

Step 4. Type in:

sudo apt-get update [press enter]

Step 5. Type in:

sudo apt-get install qgis-server python-qgis [press enter]

Do you want to continue? - [press y key]

Install these packages without verification? [press y key]

QGIS will then install and thereafter you will find it amongst your list of programs. Good luck, hope this helped.**

-2

Debian Xenial works for me. I first install bleachbit to a autoremove, clean.

The above was Google translated from:

Debian Xenial fonctionne pour moi. J'ai d'abord installé bleachbit pour faire un autoremove,clean.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.