2

I am trying to mosaic 19 rasters which i already reprojected in WGS 1984 World Mercator and then hillshading them. These are the steps i follow please correct me if i am doing something wrong.

enter image description here

I am am using the mosaic to new raster tool , i have been referring to this question Mosaic to New Raster tool fail so i am not creating the raster dataset in the same location where the rasters are stored (used Desktop in this case). I made sure that the pixel type and the number of bands are the same.

enter image description here

The result is acceptable.

enter image description here

Here comes the problem. Now i hillshade this raster. At first look appears to be ok but when i zoom in as you can see in the image below the hillshade comes with some grid like lines. I don´t understand what am i doing wrong.

enter image description here

  • Although original rasters are integer I suggest mosaic to 32 float. Also use blend in mosaic operation, it might help if they overlap. If they have gaps on the boundary you have to fill them by mean – FelixIP Apr 30 '16 at 21:44
  • There are no gaps and no overlap as you can see in the image above before i hillshade it. That was weird to me because after the mosaic everything appears good. Even after i hillshade it there are no gaps and overlap. The thing that worried me was the result after the hillshade. – Marian Pepa May 1 '16 at 11:34
1

It seems like a an resampling issue. I guess you used Nearest Neighbor, which is also the defualt setting. Nearest neighbor can lead to small pixel displacement of up to half a pixel. You can try to set the resampling method to bilinear and have a look if it fits your needs better. Bilinear interpolates pixel values by leaving the cells untouched in position but interpolates the color values.

You can set this when you open the tool and then with the button "environment" that you have beside "ok" and "cancel". There you have the options for the raster creation. Just set it from Nearest Neighbor to one of the others (don´t mix it with the options for pyramid creation which is in the same tab).

  • I forgot to mention above that i reprojected all rasters with bicubic method. Do i have to do it with bilinear method ? – Marian Pepa May 1 '16 at 11:25
  • Another question , everytime i must hillshade i have to go to Enviroments... >Raster Storage and change resampling method ? – Marian Pepa May 1 '16 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.