1

I'm trying to understand how can add a layer from my GeoServer without have to basic authenticate.

The problem is when in QGIS I try to add a WMS layer and I put as URL as http://localhost:8080/geoserver/my_ws/wms? If I do that it doesn't show anything. I've noticed that my workspace(my_ws) requires a basic authentication (username and password). If I preview any layer of my workspace it works fine, and I don't need any identification.

I'm using GeoNode and for that, GeoNode has a authprovider. My default is Basic authentication username/password.

How can I add a WMS layer to QGIS without authentication?

  • turn off authentication for your workspace – Ian Turton May 3 '16 at 14:52
  • yes, but how can i do that? – ePascoal May 3 '16 at 14:54
  • 2
    By default it is off. Have you been experimenting with authentication of do you have services which you want to require authentication? – user30184 May 3 '16 at 14:57
  • I'm using geonode and for that, geonode has a authprovider.my default is Basic authentication username/password – ePascoal May 3 '16 at 14:58
  • geonode authentication is handled by django which is independent to geoserver. It works for me without any authentication. – neogeomat Jul 24 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.