Having an issue in QGIS 2.10 -- clip and intersect don't seem to be working correctly. I am trying to show zipcode by a legislative district in Florida. When I clip the zipcode shapefile by the district one, some of the zip codes aren't being clipped (or intersected -- I'm getting the same result with both tools).

In the below screenshot, the bronze color is what both tools are giving me as an output. It should be giving me the bronze vectors + the areas that are blue-violet (created by the overlay of the semi-transparent blue district shapefile and the purple zip code shapefile). I don't understand why this isn't working, it seems pretty simple to me, but am I missing something?

screenshot of clip and intersect problem

The data for this project is here if needed: https://www.dropbox.com/s/ee70m26gdcvgbd8/FL%20HD%2069.zip?dl=0

Both shapefiles are from the US Census and are projected in NAD83.

I tried selecting only the zip codes that would be in the district, checking the "use only selected features" box in the clip tool, and got the same results.

  • 2
    I've downloaded your data and the clip works fine. Did you use the clip tool in the Vector tool bar? have you tried using any other clip tools in the QGIS processing toolbox? – HDunn May 3 '16 at 18:05
  • 2
    Same for me, with QGIS 2.14.1. Can you upgrade to the newest version and try again? – AndreJ May 3 '16 at 18:06
  • 1
    I think there's a number of posts similar to yours (like this one) which had trouble doing similar tasks. The problem seems to lie with the QGIS version itself, I found that versions 2.10.1 and 2.12.0 did not perform the operations correctly. As @AndreJ suggested, you should upgrade to a newer version and try again. – Joseph May 4 '16 at 9:13
  • Hi all. 2.14 consistently crashes for me but I switched to the 2.8 long term release and am no longer having this problem. Thanks for your help! – JLP May 5 '16 at 15:28

I believe the red layer is what you're after, yes?

I used the "Polygon intersection" tool from the processing toolbox (under Geoalgorithms, Vector, Polygons) Polygon Intersection

  • Thanks for helping! That is what I'm after, but that method did not work and gave me the same results from my original post -- I switched versions and the normal clip tool worked fine. – JLP May 5 '16 at 15:28

As people pointed out in the comments, switching to a different version of QGIS (in my case, the 2.8 long term release) fixed this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.