3

I've created my buffer, 10 m around surrounding streets, now I need to remove all trees (points) that are within that buffer but I'm having trouble doing so! I've tried clipping but I guess my input/clip features are wrong.

Here's what I have so far, triangle symbols are the points I'm trying to get rid of on my map.

  • 2
    Clip keeps the inside features, the converse is Erase tool (advanced license required) which discards intersecting features, or start editing, select by location then hit the X for delete - this could take a long time. If neither of these work you could spatial join the points to the buffers, find the ones that have FID values from the polygons (by attributes) and delete. – Michael Stimson May 5 '16 at 3:06
  • Thank you for the feedback, I will keep those tips in mind! – JMeow May 5 '16 at 3:13
8

Try "Select by Location" and set the trees as the Target layer. Set the buffer as the Source layer.

Then, for the spatial selection method, use Are within the source layer feature or Are completely within the source layer feature.

That should select all the points within the buffer. Now, you have three options:

1) In edit mode, open the 'Trees' attribute table, right click one of the highlighted records and delete them.

2) Similar to 1) you can easily delete selected features without the need for entering Edit mode by running the Delete Features tool. Be aware if you have no selected features then this tool will default to deleting everything and there is no undo for this action!

3) Open the 'Trees' attribute table, reverse the selection, then right click the layer in the table of contents Data > Export data as a new feature class or shapefile.

http://desktop.arcgis.com/en/arcmap/10.3/map/working-with-layers/using-select-by-location.htm

  • 2
    @JMeow if this has worked for you please consider marking it as the answer – Midavalo May 5 '16 at 5:06
2

As commented by @MichaelMiles-Stimson, instead of using the Clip tool I think you should examine Erase:

Creates a feature class by overlaying the Input Features with the polygons of the Erase Features. Only those portions of the input features falling outside the erase features outside boundaries are copied to the output feature class.

Erase requires an Advanced level license but if you are using Basic or Standard then there are easy workarounds documented on this site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.