2

I understand that coordinate system mismatches between layers is a relatively common problem. Nevertheless, exploring other posts hasn't helped me understand my issue. In short, I have a DEM raster and a KML route, and they should overlap based on geography alone, but they do not.


DEM File

I have downloaded a Vermont statewide DEM raster (the top option, "ALL_Elevation...") from this link: http://vcgi.vermont.gov/opendata. The data is in the NAD83 coordinate system per the included metadata text file.


KML File

I also have a KML file of a hike in Vermont in the WGS84 coordinate system. I'd post it here, but unfortunately, I cannot find a method of uploading the file with this post! It was generated using a GPS watch, and it happily imports into Google Earth without an issue. (I can send along the route if it may help troubleshoot this issue. Please just let me know.)


Attempts at a Solution

I've tried to first add the DEM file, set the project coordinate reference system (CRS) to NAD83 to match the DEM, enable "on the fly" CRS transformation, and then add the KML file. This did not work.

The opposite order didn't work either (i.e., first add the KML file, set the CRS to WGS84, enable "on the fly" CRS transformation, then add the DEM).

I've also attempted to add just the KML file to a new project and "reproject" the file using Save As and saving the file with a new name and using the NAD83 CRS. Adding the new and "reprojected" layer didn't overlap the DEM either.

Lastly, I've read in another post that data using a WGS84 CRS will have negative easting values. I would tack on the negative sign to all easting values just to try this, but I'm uncertain how to access the raw KML data.


Software Info

I'm running OS X 10.11.4 with QGIS 2.4.0 Chugiak.


UPDATE

Although I still haven't figured out what is going wrongly here, I do think that the issue is related to QGIS being unable to identify all the pertinent CRS information from the DEM layer. I think that a solution may involve defining a custom CRS using the "right" Proj4 code that matches my DEM. Proj4 codes can be found here: http://www.spatialreference.org. I've tried a couple different custom CRS ideas, but nothing works yet...

  • 1
    I'm not finding the layer you mentioned, but every DEM layer I looked at said it was using the NAD83 Vermont State Plane zone (meters). Try EPSG:32145 – mkennedy May 9 '16 at 2:09
  • Can you add the EPSG codes to your question? There are many CRS based on NAD83, but only EPSG:32145 should be chosen (as mkennedy notes). And maybe you should update to QGIS 2.14.2. – AndreJ May 10 '16 at 6:21
2

I've solved my issue. Long story short, I was importing the wrong elevation model file. See, the elevation data with which I'm working is an ArcGIS grid, so several files work together to provide a meaningful elevation model in QGIS. (Forgive the triviality here, but this is new to me. In my case, I was importing dem_10.ovr, which appears coherent when alone in QGIS, but the "correct" option was hdr.adf, which I think is the header file or something? Recall that I included a link to the Vermont state data I used in my question above.)

The main takeaway is that even if a file in a certain elevation model directory "appears" to be correct upon importation, it still may not be the correct file to use, because it may not connect to or contain all the pertinent information QGIS needs to re-project the data. If re-projecting the data doesn't seem to look right, one possible issue (if you're a newb like me) is that you're importing the incorrect elevation model file!

1

If you've access to ArcGIS, open a new map, add a 'basemap' from the server, with a known coordinate system, and then add your two data files. One or both of them will come in without a defined coordinate system. Then change the coordinate system on the MXD until they all line up properly. The one that works will be the coordinate system to assign to your KML or DEM. WGS84 is the one I recall, for the KML.

For access to the raw KML data, try opening the file as a .txt, .csv or the like. I recall it comes out as pairs of lat-long points. Some parsing required to get things into the proper columns.

This may also be helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.