0

When I use edge snapping in spatial adjustment to connect two layers, I find that it works on the lines which are close to each other (about 3 meters). But when the distance became large (about 8 meters), it does not work.

I tried to set the snap tolerance, but it did not work too. enter image description here

closed as unclear what you're asking by Midavalo, Michael Stimson, Fezter, PolyGeo May 10 '16 at 8:56

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • are you trying to set Snapping Options to force your edge snap to work? Or for your mouse to snap to a vertex/edge? – Midavalo May 10 '16 at 2:05
  • I tried to use edge snap – chrimiway May 10 '16 at 2:15
  • Snapping options won't affect the edge snap. You need to set your edge snap options on the Spatial Adjustment toolbar – Midavalo May 10 '16 at 2:16
  • Im using arcgis 10.3 – chrimiway May 10 '16 at 2:17
  • Really ?....but i didn't find an option about tolerance or something – chrimiway May 10 '16 at 2:18
1

I find the solution. To set the tolerance for edge match tool, you have to set the tolerance there "Click the Editor menu, point to Snapping, then click Options."

For more info, http://help.arcgis.com/EN/ARCGISDESKTOP/10.0/HELP/index.html#/Setting_the_snapping_tolerance_classic_snapping/001t00000048000000/

0

Try to use the default snapping of 10 pixel and see if that solve the problem. As 100000000 is too big snapping tolerance. Also check if the projection that you are using is correct. Sometime the conflict in projections, especially if you are adding several shapefiles with different projections in the same map view, can cause such an issue.

  • sorry, It did not work on 8 meters. And i even have some lines whose distance between each other are beyond 20 meters. – chrimiway May 10 '16 at 1:56
  • What projection are you using? – ahmadhanb May 10 '16 at 1:58
  • Gauss, Beijing54 19n – chrimiway May 10 '16 at 2:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.