1

I am trying to create a new network dataset within a feature dataset in a file geodatabase and keep getting the error "could not create network dataset. Cannot acquire a lock. Cannot acquire a lock." Has anyone come across this issue?

closed as off-topic by PolyGeo Sep 6 '16 at 7:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    That's because something else is accessing the database... close ALL Esri software, open one (and only one) ArcCatalog and try again. That should release the locks. If your database is in a network location it gets more complicated, in a file GDB you can tell the locks by looking into the database with explorer (or analogue) by looking for a sr.lock file, this will tell you what process (by PID) and computer it's being locked. – Michael Stimson May 11 '16 at 2:03
  • I tried copying the geodatabse onto a memory stick and creating the network dataset within this - this solved the problem. – J Clifford May 13 '16 at 10:27