2

I have a layer with graduated styling based on an integer column. When I duplicate the layer to make a similar styling based on another integer column, none of the columns are available for graduated styling of the duplicate layer.

The layer is a shapefile and all the fields of all the integer columns have a value. The same problem occurs when I save as a new shapefile, add it and try to apply graduated styling.

Why isn't it showing up in the list?

  • what are the column names? I had an issue with the name being all numeric the other day. – Ian Turton May 12 '16 at 9:16
  • OmmInt, BelInt and SkyInt. – Henrik May 12 '16 at 9:19
  • What QGIS version are you using? Might sound strange but have you tried creating new integer fields, copying the values over and then try and use those fields for styling. I was forced to do this once for an older QGIS version (can't remember which it was). – Joseph May 12 '16 at 9:42
  • I'm using 2.8.9. Your method did work, @Joseph, but it made the original layer lose its graduated styling options. – Henrik May 12 '16 at 10:35
  • 1
    @Joseph, so I managed to replicare the issue in 2.14.2. However, I tried putting the integer values into real number fields, which seems to solve the problem. Now I can copy the layer freely and the real number fields appear as options for graduated on all copies of the layer. – Henrik May 26 '16 at 8:55
2

For some reason integer fields aren't always recognized as valid for graduated styling. Putting the integer values into real number fields solves the problem. Now I can copy the layer freely and the real number fields appear as options for graduated on all copies of the layer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.