1

I'm trying to serve some MrSID files with GeoServer following the geoserver.org guide, however, I can't get the MrSID Raster Data Source to show up when attempting to add a new GeoServer Store.

This is what I did from the guide to get started:

  1. Download and Install all OpenGeo 4.8 Components
  2. Stop the Geoserver
  3. Download geoserver-2.8.3-gdal-plugin.zip[1] and extract contents to E:\OpenGeo\jetty\webapps\geoserver\WEB-INF\lib
  4. Download gdal_data.zip[2] and extract contents to E:\GDAL\data
  5. Add System Environment Variable | Variable: GDAL_DATA, Value: E:\GDAL\data
  6. Download gdal-1.9.2-MSVC2010.zip[3] and extract contents to E:\GDAL\bin
  7. Add ;E:\GDAL\bin to the end of my PATH variable
  8. Open command prompt at E:\GDAL\bin and run 'gdalinfo --formats' a list of formats was displayed
  9. cd to E:\GDAL\bin\javainfo and run 'gdalinfo.bat --formats' a list of formats was displayed
  10. Download gdal-19-1600-mrsid.msi[3] Install to C:\Program Files (x86)\GDAL
  11. Add System Environment Variable | Variable: GDAL_DRIVER_PATH, Value: C:\Program Files (x86)\GDAL\gdalplugins
  12. Start GeoServer and check to see if the MrSID option is available (it is not.)

I also found the following in my log file at E:\OpenGeo\jetty\logs\2016_05_13.stderrout.log

May 13, 2016 3:08:18 PM it.geosolutions.imageio.gdalframework.GDALUtilities loadGDAL
WARNING: Failed to load the GDAL native libs. This is not a problem unless you need to use the GDAL plugins: they won't be enabled.
java.lang.UnsatisfiedLinkError: no gdaljni in java.library.path

Download Links:

  1. http://geoserver.org/release/maintain/
  2. http://demo.geo-solutions.it/share/github/imageio-ext/releases/1.1.X/1.1.13/native/gdal/
  3. http://demo.geo-solutions.it/share/github/imageio-ext/releases/1.1.X/1.1.13/native/gdal/windows/MSVC2010/

Can you help getting GeoServer to serve MrSID files?

  • When you list the formats (as in Step 8 and 9, but after you do the .msi install) are you seeing the MrSID format listed? That is what those steps are trying to get you to do. – BradHards May 15 '16 at 5:43
  • Yes. After installing the MSI I see MrSID (rov): Multi-resolution Seamless Image Database (MrSID) at the top of the formats list for both methods. – craM 4D-61-72-63 May 16 '16 at 14:16
  • @Brad I should also note that if I run the command gdalinfo --formats from a folder outside of the one where I extracted gdal-1.9.2-MSVC2010.zip I dont see the line about MrSID. – craM 4D-61-72-63 May 16 '16 at 16:58
  • Sounds like a PATH env-var problem. In the guide, there is a warning that says "If you are on Windows, make sure that the GDAL DLL files are on your PATH." – BradHards May 16 '16 at 22:28
1

My only solution to getting MrSID working with geoserver was to uninstall the OpenGeo suite and install geoserver 2.8.3 directly. Then following the above steps worked as expected.

OpenGeo suite appears to only support MrSID in its Enterprise version: http://suite.opengeo.org/docs/latest/dataadmin/mrsid/index.html

  • Same for me. There was something with GDAL in C:\OSGeo4W getting picked up before it got to the GeoServer GDAL files. QGIS still seems to work alongside GeoServer as a standard installation, just not with the full OSGeo4W install. – Nate Wanner Oct 17 '16 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.