11

I have gone into Composer and specified the page background to be transparent. It still comes out white. Is there a solution?

20

Steps for QGIS 3.6

A few things have been moved and renamed from QGIS 2.x (see below), this is how it works in 3.x:

Open a new Print Layout (formerly "Composer"): Menu Project - New Print Layout

Right click somewhere on the white empty page, click "Page Properties". In the right sidebar the "Item Properties" tab will be activated, modify the background colour opacity to 0.

Screenshot page properties context menu

For each map item then select it, and in the right sidebar simply untick "Background".

Screenshot background checkbox

Steps for QGIS 2.4

First make the page background transparent in the sidebar under Composition - Page Settings - Page Background

enter image description here

Then for each map or item go to Item properties - Background and turn that off.

if you are trying to do this in QGIS 3.0, right click on the layout whitespace and select Page Properties. The setting to change the background is at the bottom of this dialog box.

enter image description here

Then you can export to a file format that supports transparency, i.e. PNG, via Composer - Export as image

enter image description here

| improve this answer | |
  • I will try this today. Thank you chrki. As someone just starting to understand QGIS your help is greatly appreciated. – Geoff Fox May 14 '16 at 19:02
  • I'm new to using QGIS. I'm on v3.4.13 on a mac. I can't see a Composer window. When I make a new Print Layout (is this the new name for Composer?) I can't see a Page Settings option. In "Item Properties" --> Map I have set the background to transparent, but my layer still appears solid when I export as PNG. – tomh Nov 20 '19 at 17:27
  • @tomh Yes, Composer is now "Print Layout". I added screenshots for QGIS 3 in my answer – chrki Nov 20 '19 at 21:21
  • many thanks - also I realised later that the PDF does export with transparency. But there is a white solid layer within it that can be removed when opened in Illustrator. – tomh Nov 21 '19 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.