2

I am preparing the map of Nepal with 75 districts using the KMZ file downloaded from global admin. I opened the KMZ file (NPL_admin3.kmz) in google earth pro. I produced the map, and also worked successfully with coloring the districts. But I could not put the name of the 75 districts in the map. In other GIS tools such as DIVA or Quantum, when we 'add label' under the 'layer' menu bar, we get the name associated to the boundary. But in google earth pro, I have been facing difficulty. Can anyone please help me?

  • A bypass route of displaying 'Label' in Google Earth using Quantum GIS(QGIS) is possible. – Sandipan Saha May 17 '16 at 8:52
  • If possible have someone create centroids for the polygons you wish to label (or manually add a pin to each poly.) Place all the points in one folder. Then format the points folder and on the icon dialog pick No Icon. The text will not scale as a true label would. – rheitzman Jul 27 '16 at 20:54
  • Neither of these worked for me. – Jim Garner Feb 25 at 14:21
1

Try this. Rename your kmz to zip. Open the zip and rename the kml to txt (or just use open with).

With your kml open in notepad or some other text editor look for the part of the html that says "LabelStyle" and change the "scale" number (Mine said 0 and I changed it to 0.666667) delete the entry for anything else (mine had color set to a string of 0's). Save the edited text file and rename back to kml. Save the modified zip file and rename to kmz. This worked for me... some variation will likely work for you, but dynamic labels are what they are. I just let it label with the field it had already defaulted to... which in my case was a useful field... but you might need to modify something else in the html in your case.

Here is the unlabeled points Unlabelled points

Made a copy of the kmz and renamed to zip Renamed and open in Winzip

Renamed the kml in the zip to txt Renamed kml to txt

Opened the text file and did a find for "LabelStyle" Find string in text file

Deleted the "color" text and changed the "scale" value to 0.666667 Edited text file

Saving and naming things back the way they were Rename text to kml and save edits to Zip

rename your zip to kmz and open in GE

Labelled in GE

  • oh...copy your kmz first... do this on a copy... I don't want to be contributing to your grief – Mike May 17 '16 at 16:49
  • This sounds like a good answer, but I'd be interested in a few screenshots to show the process and the result. Any chance you could edit your answer to include some? – Midavalo May 17 '16 at 18:29
0

A bypass route of displaying 'Label' in Google Earth using Quantum GIS(QGIS) is possible. At first import the .kml file into QGIS & save it as .kml data during saving procedure mention 'Name' of the field you want to display as label from 'NameField' under 'Datasource Options'....

Saving as .kml from QGIS

0

I experienced this issue with a kml file produced from ArcGIS tool Layer to KML. In my case, the label "scale" and "opacity" properties were set to zero for all features. I figured out a way to solve the issue through the Google Earth interface. By right-clicking on the layer (or individual features) and going to "Properties", then clicking on the "Style, Color" tab, I was able to get my labels to show by increasing the scale to e.g. 1 and the opacity to e.g. 100%. This is basically what @Mike is doing programmatically by opening the KML as a zip/text file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.